
การใช้โปรแกรม SPSS ในการวเิคราะห์ข้อมูลทางสถิตเิพือ่การวจิัย 
SPSS ยอ่มาจาก Statistical Package for Social Science 
โปรแกรม SPSS ท่ีใชใ้นการอบรมคร้ังน้ีจะใช ้ SPSS for Windows Version 12.0 
การตดิตั้งโปรแกรม 

1. นาํแผน่ซีดีโปรแกรม SPSS for Windows Version 12.0 ใส่ซีดีรอมไดร์ฟ  
2. ดบัเบิลคลิก My Computer  
3. ดบัเบิลคลิกซีดีรอมไดร์ฟ  
4. ดบัเบิลคลิกโฟลเดอร์ SPSS v12.0  
5. ดบัเบิลคลิกไอคอน SPSS12.exe  
6. คลิกปุ่ม Next  แลว้รอ  
7. คลิกปุ่ม Next  
8. คลิกตรงวงกลมหนา้ I accept the terms in the license agreement  
9. คลิกปุ่ม Next 6 คร้ัง  
10. คลิกปุ่ม Install แลว้รอ  
11. คลิกปุ่ม Finish  
12. คลิก Start -> Run  
13. ตรงบรรทดั Open ใหพิ้มพ ์C:\Program Files\SPSS\licrenew.exe กดปุ่ม OK  
14. ปรากฏหนา้จอ  

ใหพิ้มพ ์30066743322 กด Enter 
ใหพิ้มพ ์30066743322 กด Enter 
กด Enter 

 
การเรียกใช้โปรแกรม 
 คลิก Start -> All Programs -> SPSS for Windows -> SPSS 12.0 for Windows 

ถา้ปรากฏหนา้จอ What would you like to do? ใหค้ลิกส่ีเหล่ียมดา้นล่างซา้ยใหมี้เคร่ืองหมายถกู แลว้
คลิกปุ่ม OK คลิกปุ่ม Cancel 

 
หมายเหตุ กรณีปรากฏหน้าจอ 

 



ถ้าต้องการไม่ให้ปรากฏหน้าจอนี ้
1. ดบัเบิลคลิก My Computer  
2. ตรงบรรทดั Address ใหพิ้มพ ์C:\Program Files\SPSS แลว้กด Enter  
3. เล่ือน Vertical Scroll Bar จนปรากฏช่ือไฟล ์expoff.bat  
4. ดบัเบิลคลิกตรงไฟล ์expoff.bat  
5. ปิดหนา้จอ  

 
Windows ของ SPSS ม ี5 ประเภท 

1. Data  ไฟลน์ามสกลุ sav  ใชเ้พิ่ม/แกไ้ข/ลบ ขอ้มูล หรือ เรียกขอ้มูล  
ท่ีป้อนจากโปรแกรมอ่ืนๆ 

2. Output  ไฟลน์ามสกลุ spo  เพื่อใหแ้สดงผลลพัธ์ในรูปแบบ Graphics  
3. Syntax  ไฟลน์ามสกลุ sps  ใชพิ้มพค์าํสั่งหาค่าทางสถิติ แทนการใชเ้มนู  
4. Draft Output ไฟลน์ามสกลุ rtf  เพื่อใหแ้สดงผลลพัธ์ในรูปแบบ Text  
5. Script  ไฟลน์ามสกลุ sbs  ใชเ้ขียนโปรแกรมคาํสั่งหาค่าทางสถิติ  

หมายเหตุ ในการอบรมใช ้Windows เฉพาะขอ้ 1 และขอ้ 2 ส่วนคาํสั่งหาค่าทางสถิติจะใชเ้มนู 
 
การป้อนข้อมูลจากหน้าจอ Data มขีั้นตอน 

1. เปิดหนา้จอ SPSS Data Editor เลือกเมนู File -> New -> Data 
2. การกาํหนดช่ือและรายละเอียดของตวัแปร จากหนา้จอ Variable View 
3. ป้อนขอ้มูล จากหนา้จอ Data View 
4. บนัทึกขอ้มูล เลือกเมนู File -> Save 

ต้องการให้หน้าจอ Data แสดงภาษาไทย ให้การแก้ไขฟอนต์ ดงันี ้
เลือกเมนู View -> Fonts 

 
เลือก Font และ Size ตามท่ีตอ้งการ แลว้คลิกปุ่ม OK 
หมายเหตุ ช่ือฟอนตท่ี์เป็นภาษาไทยส่วนใหญ่จะลงทา้ยดว้ย UPC 



ตวัอย่างข้อมูล ช่ือตวัแปร sex ประเภทตวัเลข ความกวา้ง 1 ไม่มีจุดทศนิยม เลเบล เพศ  
การกาํหนดช่ือและรายละเอยีดของตวัแปร จากหน้าจอ Variable View 

ท่ีหนา้จอ SPSS Data Editor เรียกหนา้จอ Variable View ทาํได ้2 วธีิ 
1. ดบัเบิลคลิกตรงคอลมัน์ของบรรทดัแรก  
2. คลิกแถบ Variable View ท่ีอยูด่า้นล่าง  

 
1. Name ช่ือตวัแปร ใหพิ้มพต์รงคอลมัน์ Name เช่น Sex  
2. Type ประเภทของตวัแปร  

 
เลือก Numeric Width=1 Decimal Places=0 คลิกปุ่ม OK  

3. Label  กาํหนดขอ้ความขยายช่ือตวัแปร เพื่ออธิบายช่ือตวัแปรและแสดงออกทางผลลพัธ์  
ใหพิ้มพต์รงคอลมัน์ Label เช่น เพศ 

4. Values กาํหนดคาํอธิบายใหก้บัค่าตวัแปร  

 



5. Missing กาํหนดค่าท่ีไม่นาํไปวเิคราะห์ มี 2 แบบ  
5.1 User Missing ผูว้จิยัเป็นผูก้าํหนด เช่น 9, 99, 999, … 

 
5.2 System Missing โปรแกรมจะกาํหนดใหเ้อง 

6. Column จาํนวนความกวา้งของคอลมัน์ คือจาํนวนความกวา้งมากสุดของ ค่าตวัแปร หรือ ช่ือตวัแปร 
หรือ label ตวัแปร  
จากตวัอยา่ง ช่ือตวัแปร และ label ตวัแปร มีความกวา้งมากสุดเท่ากบั 3 
ใหพิ้มพ ์4 (ความกวา้งมากสุดเท่ากบั 3 บวกเผือ่ไว ้1) 

7. Align ใหแ้สดงค่าตวัแปร ชิดซา้ย ก่ึงกลาง ชิดขวา  
8. Measure ระดบัการวดัของขอ้มูล  

7.1 Scale (Interval, Ratio) 
7.2 Ordinal 
7.3 Nominal 

ใหก้าํหนดช่ือและรายละเอียดของตวัแปรใหค้รบทุกตวั 
ป้อนข้อมูล จากหน้าจอ Data View 

 
Data View เป็นแบบตาราง การป้อนขอ้มูลจะคลา้ยกบั Excel 
บรรทดัแรก จะเป็นช่ือตวัแปร 
บรรทดัต่อไป จะเป็นขอ้มูล 
ดูจาํนวนขอ้มูล ไปรายการสุดทา้ย กดปุ่ม Ctrl+End 
กลบัไปรายการแรก กดปุ่ม Ctrl+Home 
การ Show Label (View -> Value Labels) 



การนําข้อมูลเข้าจาก Excel 
ใหก้อ็ปป้ีไฟลทุ์กไฟลท่ี์อยูใ่นโฟลเดอร์ train_spss\data จากแผน่ซีดี ไปเกบ็ไวท่ี้โฟลเดอร์ C:\train_spss\data 
เง่ือนไข 

1. ไฟลท่ี์จะนาํเขา้ตอ้งไม่เปิดคา้งไวท่ี้ Excel  
2. ขอ้มูลท่ีป้อนใน Excel ตอ้งเป็นแบบ Numeric ไม่เป็นแบบ String เช่น ‘1  
3. บรรทดัแรก ตอ้งเป็นช่ือตวัแปร บรรทดัต่อท่ี 2 เป็นตน้ไปจะเป็นขอ้มูล  

การนาํเขา้ 
1. เลือกเมนู File -> Open -> Data  

 
File of type  เลือก Excel (*.xls) 
Look in เลือก C:\train_spss\data\tinybus.xls 
คลิกปุ่ม Open 
คลิกปุ่ม OK 

2. เลือกเมนู File -> Save As  

 
Save as type  เลือก SPSS (*.sav) 
Save in  เลือกช่ือ Drive ตามดว้ยช่ือพ้ืนท่ีใน Harddisk เช่น C:\train_spss\data 
File name พิมพช่ื์อไฟล ์เช่น tinybus 
คลิกปุ่ม Save 
หลงัจากท่ีไดไ้ฟล ์tinybus.sav ส่ิงแรกท่ีตอ้งทาํคือ กาํหนดรายละเอียดแต่ละตวัแปร 



การเปลีย่นแปลงข้อมูลก่อนนําไปวเิคราะห์ข้อมูลทางสถิติ 
1. การเปล่ียนแปลงเก่ียวกบัตวัแปร  
2. การสร้างตวัแปรใหม่จากการคาํนวณและเง่ือนไข  
3. การเลือกขอ้มูลมาทาํการวเิคราะห์  
4. การดาํเนินการอ่ืนๆ กบัขอ้มูล 

1. การเปลีย่นแปลงเกีย่วกบัตวัแปร 
 ตอ้งการเปล่ียนแปลงรายละเอียดตวัแปรใดให ้ดบัเบิลคลิกท่ีช่ือตวัแปร จากหนา้จอ Data View 
 ตอ้งการเปล่ียนค่าตวัแปร ทาํได ้2 ลกัษณะ 

 การเปล่ียนค่าในตวัแปรเดิม วธีิน้ีไม่เป็นท่ีนิยม 
 การเปล่ียนค่าและสร้างเป็นตวัแปรใหม่ 

ท่ีหนา้จอ Data View เลือกเมนู Transform -> Recode -> Into Different Variables 
ตวัอย่าง เปล่ียนค่าตวัแปร sex จาก 1 เป็น 3, 2 เป็น 4 สร้างตวัแปรใหม่ช่ือ newsex 

 
คอลมัน์ซา้ยของหนา้จอเลือกตวัแปร SEX คลิกปุ่ม  
คอลมัน์ Output Variable 
 Name  พิมพ ์ newsex 
 Label พิมพ ์ ตวัแปรเพศใหม่ 
 คลิกปุ่ม Change 
คลิกปุ่ม Old and New Values 



 
คอลมัน์ Old Value  Value พิมพ ์ 1  คอลมัน์ New Value  Value   พิมพ ์  3  คลิกปุ่ม Add 
คอลมัน์ Old Value  Value พิมพ ์ 2 คอลมัน์ New Value  Value   พิมพ ์  4  คลิกปุ่ม Add 
คลิกปุ่ม Continue 
คลิกปุ่ม OK 
ตวัแปรใหม่ newsex จะต่อจากคอลมัน์สุดทา้ย 
ตวัอย่าง เปล่ียนค่าตวัแปร age โดยกาํหนดเป็นช่วง และสร้างตวัแปรใหม่ช่ือ newage 
 1 เท่ากบั นอ้ยกวา่ 25 ปี 
 2 เท่ากบั 25 ปี ถึง 34 ปี 
 3 เท่ากบั 35 ปี ถึง 44 ปี 
 4 เท่ากบั ตั้งแต่ 45 ปีข้ึนไป 

 
เลือก Range Lowest through  พิมพ ์ 25 Value  พิมพ ์ 1 คลิกปุ่ม Add 
เลือก Range พิมพ ์ 25  through  พิมพ ์ 34 Value  พิมพ ์ 2 คลิกปุ่ม Add 
เลือก Range พิมพ ์ 35  through  พิมพ ์ 44 Value  พิมพ ์ 3 คลิกปุ่ม Add 
เลือก Range พิมพ ์ 45  through highest Value  พิมพ ์ 4 คลิกปุ่ม Add 
คลิกปุ่ม Continue 
คลิกปุ่ม OK 



2. การสร้างตวัแปรใหม่จากการคาํนวณและเงือ่นไข 
ตวัอยา่ง เปิดไฟล ์DATA.sav สร้างตวัแปรใหม่ช่ือ newincome โดยเพิ่มรายไดข้ึ้น 10% จากตวัแปร income 
เฉพาะเพศหญิง 
เลือกเมนู Transform -> Compute 

 
Target Variable พิมพ ์newincome 

เลือกตวัแปร income คลิกปุ่ม  
Numeric Expression พิมพ ์income * 1.1 
คลิกปุ่ม Type & Label 

 
Label พิมพ ์เพิ่มรายไดเ้พศหญิง 
คลิกปุ่ม Continue 



คลิกปุ่ม If 

 
เลือกตวัแปร sex คลิกปุ่ม  
เลือก Include if case satisfies condition 
พิมพ ์sex = 2 
คลิกปุ่ม Continue 
คลิกปุ่ม OK 

3. การเลอืกข้อมูลมาทาํการวเิคราะห์ 
ปกติโปรแกรมนาํขอ้มูลทั้งหมดใน Data View มาทาํการวเิคราะห์ ถา้ผูว้จิยัตอ้งการเลือกขอ้มูลบางชุดมาทาํ
การวเิคราะห์ ใหเ้ลือกเมนู Data -> Select Cases 

 



All cases ขอ้มูลทั้งหมด ทุกชุด ทุกตวัแปร 
If condition is satisfied เลือกชุดขอ้มูลตามเง่ือนไขท่ีกาํหนด 
Random sample of cases เลือกขอ้มูลดว้ยวธีิสุ่มโดยกาํหนดจาํนวนชุดขอ้มูลท่ีตอ้งการจากการสุ่ม
โดยประมาณ (Approximately) หรือ จาํนวนชุดขอ้มูลท่ีแน่นอน (Exactly) 
Base on time or cases range เลือกชุดขอ้มูลโดยใชล้าํดบัของชุดขอ้มูลเป็นตวักาํหนด 
Use Filter variable เลือกชุดขอ้มูลโดยใชค้่าของตวัแปรท่ีมีอยูเ่ป็นตวักาํหนด 
Unselected Cases Are 
 Filtered เป็นการเลือกชุดขอ้มูลแบบชัว่คราว ถา้ตอ้งการกลบัมาเลือกขอ้มูลทั้งหมด 

 ใหเ้ลือกเมนู Data -> Select Cases -> All case 
 Deleted เป็นการเลือกชุดขอ้มูลแบบถาวร โดยท่ีขอ้มูลท่ีไม่ถกูเลือกจะถกูลบออกจาก Data View 
   แต่ไม่มีผลต่อขอ้มูลของไฟลข์อ้มูลเดิมถา้ไม่บนัทึก 

ตวัอย่าง ตอ้งการเลือกชุดขอ้มูลเฉพาะเพศชาย 
 เลือกตวัแปร sex 
 เลือก If condition is satisfied 
 คลิกปุ่ม If 
 

 
 เลือกตวัแปร sex คลิกปุ่ม  

พิมพ ์sex = 1 
คลิกปุ่ม Continue 

 เลือก Deleted 
 คลิกปุ่ม OK 
 หมายเหตุ  

1. หา้มสั่งบนัทึก จากเมนู File -> Save เพราะจะทาํใหข้อ้มูลเดิมสูญหาย  
2. ถา้ตอ้งการนาํชุดขอ้มูลน้ีไปวเิคราะห์คร้ังต่อไป ใหบ้นัทึกช่ือไฟลใ์หม่  

จากเมนู File -> Save As 



 
4. การดาํเนินการอืน่ๆ กบัข้อมูล 

การเรียงลาํดบัขอ้มูล   เลือกเมนู Data -> Sort Cases 
การกาํหนดนํ้าหนกัแก่ชุดขอ้มูล เลือกเมนู Data -> Weight Cases 
การสลบัท่ีตวัแปรและชุดขอ้มูล เลือกเมนู Data -> Transpose 
การแบ่งขอ้มูลเป็นกลุ่มยอ่ย  เลือกเมนู Data -> Split File 

การเปล่ียนแปลงขอ้มูลของโปรแกรม เลือกเมนู Edit -> Options



การวเิคราะห์หาสถิตพิืน้ฐาน 
การสร้างตารางแจกแจงความถี่แบบทางเดยีว 

เป็นการแจกแจงขอ้มูลตามลกัษณะใดลกัษณะหน่ึงของขอ้มูลเพียงลกัษณะเดียว หรือจาํแนกค่าของขอ้มูลโดย
ใชต้วัแปรตวัเดียว 

ตวัอย่าง ตอ้งการทราบความถี่ของระดบัการศึกษา 
1. เปิดไฟลข์อ้มูล data.sav  
2. เลือกเมนู Analyze -> Descriptive Statistics -> Frequencies  

 
เลือกตวัแปร Level of education คลิกปุ่ม  
หมายเหตุ โปรแกรมจะแสดง Label แทนช่ือตวัแปร 
คลิกปุ่ม OK จะไดผ้ลลพัธ์ดงัน้ี 

 



ความหมายของผลลพัธ์ 
คอลมัน์ท่ี 1 บอกจาํนวนขอ้มูล 

Valid จาํนวนขอ้มูลท่ีนาํมาแจกแจงความถี่ 
Missing จาํนวนขอ้มูลท่ีไม่สมบูรณ์ 
Total จาํนวนขอ้มูลทั้งหมด 

คอลมัน์ท่ี 2 แสดงช่ือตวัแปร หรือ Label ของตวัแปร ตามค่าท่ีเป็นไปไดข้องตวัแปร 
คอลมัน์ท่ี 3 Frequency คือ ค่าท่ีแสดงความถ่ีท่ีนบัได ้
คอลมัน์ท่ี 4 Percent  คือ ค่าท่ีแสดงความถ่ีท่ีนบัไดใ้นรูปร้อยละ คิดจากขอ้มูลทั้งหมด 
คอลมัน์ท่ี 5 Valid Percent คือ ค่าท่ีแสดงความถ่ีท่ีนบัไดใ้นรูปร้อยละ ไม่รวมค่า Missing 
คอลมัน์ท่ี 6 Cumulative Percent คือ ค่าท่ีแสดงความถ่ีสะสมของ Valid Percent 

 
การสร้างตารางแจกแจงความถี่แบบหลายทาง 

เป็นการจาํแนกขอ้มูลตามลกัษณะของขอ้มูลตั้งแต่ 2 ลกัษณะมาแจกแจงความถี่พร้อมกนั เรียกวา่  
ตารางแจกแจงความถี่รวม (Cross tab Table) 

ตวัอย่าง ตารางแจกแจงความถี่ จาํแนกตามเพศและระดบัการศึกษา 
เลือกเมนู Analyze -> Descriptive Statistics -> Crosstabs 

 
เลือกตวัแปร sex คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Row(s) 

เลือกตวัแปร Level of education คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Column(s) 
คลิกปุ่ม Cells 



 
ตรง Percentages เลือก Row, Column, Total 
คลิกปุ่ม Continue 
คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 



ความหมายของผลลพัธ์ 
sex หมายถึง ตวัแปรท่ีแจกแจงทางดา้นแถว 
Level of education หมายถึง ตวัแปรท่ีแจกแจงทางดา้นคอลมัน์ 

Count 19 จาํนวนท่ีนบัได ้ มีเพศชายท่ีจบการศึกษา ตํ่ากวา่ปริญญาตรี 19 คน 
% within sex 30.6% จาํนวนร้อยละเม่ือ

เทียบกบัเพศชาย 
มีเพศชายท่ีจบการศึกษา ตํ่ากวา่ปริญญาตรีคิดเป็น 
30.6 % ของเพศชายทั้งหมด (62 คน) 

% within Level 
of education 

63.3% จาํนวนร้อยละเม่ือ
เทียบกบัระดบั
การศึกษา 

มีเพศชายท่ีจบการศึกษา ตํ่ากวา่ปริญญาตรีคิดเป็น 
63.3 % ของเพศท่ีจบตํ่ากวา่ปริญญาตรีทั้งหมด (30 
คน) 

% of Total 
 

19.4% จาํนวนร้อยละเม่ือ
เทียบกบัขอ้มูล
ทั้งหมด 

มีเพศชายท่ีจบการศึกษา ตํ่ากวา่ปริญญาตรีคิดเป็น 
19.4 % ของขอ้มูลทั้งหมด (100 คน) 

 
การแจกแจงความถี่แบบ Multiple Response 
 เป็นการจาํแนกหรือการแจกแจงความถี่สาํหรับตวัแปรท่ีมีค่าไดห้ลายลกัษณะ คือขอ้ถามมีการตอบ
มากกวา่ 1 ขอ้  

ตวัอย่าง ขอ้ถาม ท่านชมรายการทีวใีดบา้ง (ตอบไดม้ากกวา่ 1 ขอ้) 
 ตวัแปร v6a  ข่าว/สารคดี  
 ตวัแปร v6b  ละคร 

ตวัแปร v6c  เพลง 
ตวัแปร v6d  เกมโชว ์
ค่าของตวัแปร 1 ผูต้อบเลือกตวัเลือก 9 ผูต้อบไม่เลือกตวัเลือก  

เลือกเมนู Analyze -> Multiple Response -> Define Sets 

 



เลือกตวัแปร v6a คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Variables in Set 

เลือกตวัแปร v6b คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Variables in Set 

เลือกตวัแปร v6c คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Variables in Set 

เลือกตวัแปร v6d คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Variables in Set 
ตรง Variables Are Coded As เลือก Dichotomies Counted value ป้อน 1 ในช่องส่ีเหล่ียม 
Name ใหพิ้มพช่ื์อตวัแปรใหม่ช่ือ tv 
Label  ใหพิ้มพค์าํอธิบายตวัแปร รายการท่ีชอบ 
คลิกปุ่ม Add 
คลิกปุ่ม Close 
เลือกเมนู Analyze -> Multiple Response -> Frequencies 

 
เลือกตวัแปร รายการท่ีชอง [$tv] คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Table(s) for 
คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 



การบรรยายลกัษณะข้อมูลด้วยค่าสถิตเิบือ้งต้น 
การอธิบายหรือบรรยายลกัษณะขอ้มูลดว้ยค่าสถิติเบ้ืองตน้ เป็นการนาํขอ้มูลท่ีเกบ็รวบรวม นาํมาดาํเนินการ

หาค่าท่ีจะเป็นตวัแทนของกลุ่มขอ้มูล 
ค่าสถิติเบ้ืองตน้ท่ีหาไดจ้ะใชอ้ธิบายหรือบรรยายกลุ่มขอ้มูลในรูปของผลสรุปแทนท่ีจะนาํขอ้มูลทั้งหมดมา

นาํเสนอ ขอ้มูลท่ีจะนาํมาหาค่าสถิติเบ้ืองตน้สามารถใชไ้ดท้ั้งขอ้มูลประชากร (Population) และขอ้มูลตวัอยา่ง 
(Sample) 

ข้อมูลท่ีจะนาํมาหาค่าสถิตเิบือ้งต้นตอ้งเป็นขอ้มูลท่ีมีการวดัอยูใ่นระดบัอตัราส่วนหรือระดบัช่วง บางกรณี
อาจจะใชข้อ้มูลระดบัเรียงอนัดับ 

การหาค่าสถิตเิบือ้งต้นจําแนกได้ 4 วธีิ 
1. การหาค่าแนวโน้มเข้าสู่ส่วนกลาง (Central Tendency)  

 ค่าเฉล่ีย (Mean) เช่น 
ค่าเฉล่ียแบบเลขคณิต (Arithmetic Mean or Average, A.M),  
ค่าเฉล่ียแบบเรขาคณิต (Geometric Mean, F.M),  
ค่าเฉล่ียแบบฮาร์โมนิก (Harmonic Mean, H.M) 

 ฐานนิยม (Mode) 
 ค่าแสดงตาํแหน่งของขอ้มูล (N-Tiles) เช่น มธัยฐาน (Median), ควอไทล ์(Quartiles),  

เดไซล ์(Deciles) และเปอร์เซ็นตไ์ทล ์(Percentiles) 
2. การหาค่าการกระจายข้อมูล (Dispersion)  

 พิสัย (Range) 
 ส่วนเบ่ียงเบนควอไทล ์(Quartile Deviation) 
 ส่วนเบ่ียงเบนเฉล่ีย (Mean Deviation) 
 ส่วนเบ่ียงเบนมาตรฐาน (Standard Deviaion) 
 สัมประสิทธ์ิของการแปรผนัหรือการกระจาย (Coefficient of Variation) 

3. การหาค่าคะแนนมาตรฐาน (Standard Score)  
4. การหาค่าแสดงรูปร่างของโค้งความถี่ (Frequencies Curve, Distribution)  

 โคง้ปกติ (Normal Curve) 
 โคง้เบ ้(Skewness Curve) เช่น โคง้เบซ้า้ย, โคง้เบข้วา 
 



การหาค่าสถิตเิบือ้งต้นแบบไม่จําแนกกลุ่ม 
จากไฟล ์DATA.sav ตวัแปรท่ีสามารถคาํนวณไดคื้อ age, income 
ตวัอย่าง คาํนวณหาค่าสถิติเบ้ืองตน้ ตวัแปรอาย ุ
เลือก Analyze -> Descriptive Statistics -> Descriptives 

 
เลือกตวัแปร age คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Variable(s) 
คลิกปุ่ม Options ใหเ้ลือกค่าสถิติตามรูป 

 
คลิกปุ่ม Continue 
คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 

 



ความหมายของผลลพัธ์ 
age ช่ือตวัแปรอายท่ีุตอ้งการหาค่าสถิติเบ้ืองตน้ 
N Statistic จาํนวนขอ้มูลทั้งหมดไม่รวม Missing 
Range Statistic ค่าพิสัย 
Minimum Statistic ค่าตํ่าสุดของอาย ุ
Maximum Statistic ค่าสูงสุดของอาย ุ
Sum Statistic ค่าผลรวมของอาย ุ
Mean Statistic ค่าอายเุฉล่ีย 

Std. Error ค่าความคาดเคล่ือนมาตรฐานของค่าเฉล่ีย 
Std. Statistic ค่าส่วนเบ่ียงเบนมาตรฐาน แสดงถึงการกระจายของขอ้มูล 
Variance Statistic ค่าความแปรปรวนของขอ้มูล 
Skewness Statistic ค่าท่ีใชว้ดัความเบข้องโคง้ความถ่ี วา่โคง้ปกติหรือโคง้เบซ้า้ยหรือโคง้เบ้

ขวา 
Skewness = 0 หรือใกลศ้นูย ์โคง้ปกติ 
Skewness < 0 โคง้เบซ้า้ย 
Skewness > 0 โคง้เบข้วา 

Std. Error ค่าความคาดเคล่ือนมาตรฐานของ Skewness 
Kurtosis Statistic ค่าท่ีใชว้ดัความสูงของโคง้ปกติ 

Kurtosis = 0 หรือใกลศ้นูย ์สูงปกติ 
Kurtosis < 0 สูงมาก 
Kurtosis > 0 สูงนอ้ย 

Std. Error ค่าความคาดเคล่ือนมาตรฐานของ Kurtosis 
 
การหาค่าสถิตเิบือ้งต้นแบบจําแนกกลุ่ม 

เป็นการหาค่าสถิติเบ้ืองตน้ของขอ้มูลแต่ละกลุ่มยอ่ยเพื่อนาํมาเปรียบเทียบกนั เช่น หาอายเุฉล่ียระหวา่งเพศ
ชายและหญิง เปรียบเทียบระดบัความพึงพอใจของผูบ้ริโภคอาชีพต่างๆ 

ตวัแปรท่ีใชห้าค่าสถิตเิบือ้งต้นต้องคาํนวณได ้คือ ระดบัช่วงหรืออตัราส่วนหรือระดบัเรียงอนัดับ 
ตวัแปรท่ีนาํมาใชเ้ป็นตวัแปรกลุ่มควรเป็นตวัแปรระดบันามบัญญัตหิรือเรียงอนัดบั 
ตวัอย่าง ตอ้งการคาํนวณหาค่าสถิติเบ้ืองตน้ของอายเุฉล่ีย จาํแนกตามเพศ 
เลือกเมนู Analyze -> Compare Means -> Means 



 
เลือกตวัแปร age คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Dependent List 

เลือกตวัแปร sex คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Independent List 



คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 
ความหมายของผลลพัธ์ 

age ช่ือตวัแปรท่ีถกูนาํมาคาํนวณหาค่าสถิติเบ้ืองตน้ 
sex ช่ือตวัแปรท่ีถกูกาํหนดใหเ้ป็นตวัแบ่งกลุ่ม 

Male ค่าของตวัแปร sex 
Female ค่าของตวัแปร sex 

Mean ค่าเฉล่ียของตวัแปร age ในแต่กลุ่มของตวัแปร sex 
N จาํนวนขอ้มูล ในแต่ละกลุ่มของตวัแปร sex 
Std. Deviation ค่าส่วนเบ่ียงเบนมาตรฐานของตวัแปร age ในแต่ละกลุ่มของตวัแปร sex 

 



การตรวจสอบเคร่ืองมอืและข้อมูลทีใ่ช้ในการวจิัย 
งานวจิัยส่ิงทีถ่ือว่าสําคญัทีสุ่ด คือ ข้อมูล ก่อนท่ีจะนาํขอ้มูลไปวเิคราะห์จะตอ้งตรวจขอ้มูลก่อน 
ตวัอยา่งเคร่ืองมือในงานวจิยั เช่น แบบสัมภาษณ์ แบบสอบถาม แบบสาํรวจ เคร่ืองทอลอง ฯ  
การหาความเช่ือมัน่ของแบบสอบถามทีใ่ช้ในการเกบ็รวบรวมข้อมูล 

ตวัอยา่ง ผูว้จิยัตอ้งการหาความเช่ือมัน่ของแบบสอบถามท่ีสาํรวจจากผูใ้ชบ้ริการรถเมล ์ขสมก. จาํนวน 20 
คาํถาม มีผลตอบ 15 คน 

การใชโ้ปรแกรมช่วยในการหาค่าความเช่ือมัน่ ดงัน้ี 
1. เปิดไฟล ์DATA10A.sav  
2. เลือกเมนู Analyze -> Scale -> Reliability Analysis  

 
เลือกตวัแปรท่ีตอ้งการความเช่ือมัน่ เลือกทุกตวัคลิกปุ่ม  
Model เลือก Alpha ซ่ึงเป็นวธีิทดสอบของ Cronbach  

3. คลิกปุ่ม Statistics  

 
เลือก Scale if item deleted 
คลิกปุ่ม Continue 



4. คลิกปุ่ม OK จะไดผ้ลลพัธ์  

 
ความหมายของผลลพัธ์ 
Cronbach’s Alpha ค่าความเช่ือมัน่ของเคร่ืองมือเท่ากบั .606 
คอลมัน์ท่ี 1 คือ ตวัแปรขอ้ถาม 

Scale Mean if Item Deleted ค่าคะแนนเฉล่ียรวมทุกขอ้ถามท่ีเหลือหลงัจากลบขอ้ถามบรรทดัน้ี
ออก 

Scale Variance if Item Deleted ค่าความแปรปรวนรวมทุกขอ้ถามท่ีเหลือหลงัจากลบขอ้ถาม
บรรทดัน้ีออก 

Corrected Item-Total Correlation ค่าสัมประสิทธ์ิความสัมพนัธ์ระหวา่งคะแนนรวมทุกขอ้ถามกบั
ขอ้ถาม 

Cronbach's Alpha if Item Deleted ค่าระดบัความเช่ือมัน่ของเคร่ืองมือท่ีเหลือหลงัจากขอ้ถามบรรทดั
น้ีออก 

สรุป เคร่ืองมือท่ีใชมี้ความเช่ือมัน่เท่ากบั 0.606 อยูใ่นระดบัท่ีพอใช ้ถา้จะใหดี้ตอ้งตั้งแต่ 0.8 ข้ึนไป 
 ถา้ตอ้งการความเช่ือมัน่สูงตอ้งลบขอ้ถามท่ีแสดงค่า Cronbach's Alpha if Item Deleted สูงสุดออก 



การประมาณค่าและการทดสอบสมมตฐิานทางสถิต ิ
การประมาณค่า เป็นวธีิการอนุมานทางสถิติวธีิหน่ึง เพื่อจะหาค่าท่ีคาดวา่น่าจะเป็นค่าของขอ้มูลทั้งหมดหรือ
เรียกวา่ค่าพารามิเตอร์ของประชากร โดยใชค้่าของขอ้มูลตวัอยา่งท่ีเรียกวา่ค่าสถิติ 
การประมาณค่า คือ การประมาณคา่พารามิเตอร์ซ่ึงเป็นลกัษณะของประชากรโดยใชค้่าสถิติของขอ้มูลตวัอยา่ง 
หรืออาจกล่าวไดว้า่เป็นการประมาณค่าพารามิเตอร์ดว้ยค่าสถิติ เช่น 

ประมาณค่าเฉล่ียประชากร (�) ดว้ยค่าเฉล่ียตวัอยา่ง ( x ) 
ประมาณค่าสัดส่วนหรือร้อยละ (�) ค่าสัดส่วนตวัอยา่ง (p) 
ประมาณค่าความแปรปรวนประชาการ (�2)ดว้ยค่าความแปรปรวนตวัอยา่ง (s2) 

การทดสอบสมมตฐิานทางสถิติ เป็นวธีิการอนุมานทางสถิติวธีิหน่ึงท่ีใชต้รวจสอบสมมติฐานวจิยัท่ีผูว้จิยัคาดเดา 
แต่การตรวจสอบนั้นจะไม่ทาํกบัสมมติฐานวจิยัโดยตรงแต่จะเป็นการตรวจสอบจากสมมติฐานทางสถิติท่ีผู ้
ทดสอบตั้งข้ึนมาใหส้อดคลอ้งกบัสมมติฐานวจิยัและนาํไปสรุปสมมติฐานวจิยั 
หลกัเกณฑ์ การตั้งสมมตฐิานทางสถิต ิสมมตฐิานหลกั (H0) ต้องมเีคร่ืองหมายเท่ากบัร่วมอยู่ด้วย 
หลกัเกณฑ์ การปฏิเสธหรือยอมรับสมมตฐิาน H0 

การทดสอบค่าเฉล่ีย การทดสอบค่าสัดส่วน และการทดสอบค่าความแปรปรวน ใชห้ลกัเกณฑเ์ดียวกนั 
การทดสอบสมมตฐิานค่าเฉลีย่สําหรับ 1 กลุ่มตัวอย่าง 

สมมติฐาน เขตปฏิเสธสมมติฐาน H0 
แบบสองทาง 
(Two-tails Test) 

H0 : � = 
�0 
H1 : μ ≠  
�0 

Sig. (2-tailed) < � 

แบบทางเดียว 
(One-tails Test) 

H0 : � � 
�0 
H1 : � > 
�0 

1. 2
tailed)-(2 Sig.

< � 
2. t > 0 

H0 : � � 
�0 
H1 : � < 
�0 

1. 2
tailed)-(2 Sig.

< � 
2. t < 0 

หมายเหตุ 1. �0 เป็นค่าคงท่ี 
2. � ผูว้จิยัเป็นผูก้าํหนด 
3. สมมติฐานแบบทางเดียว จะปฏิเสธสมมติฐาน H0 กต่็อเม่ือ
เง่ือนไขทั้ง 2 ขอ้เป็นจริงเท่านั้น 

 



การทดสอบสมมตฐิานผลต่างระหว่างค่าเฉลีย่สําหรับ 2 กลุ่มตวัอย่าง 
สมมติฐาน เขตปฏิเสธสมมติฐาน H0 

แบบสองทาง 
(Two-tails Test) 

H0 : �1 -  �2 = �0 
H1 : �1 -  �2 ≠ μ 0 

Sig. (2-tailed) < � 

แบบทางเดียว 
(One-tails Test) 

H0 : �1 -  �2 � �0 
H1 : �1 -  �2 > �0 1. 2

tailed)-(2 Sig.
< � 

2. t > 0 
H0 : �1 -  �2 � �0 
H1 : �1 -  �2 < �0 1. 2

tailed)-(2 Sig.
< � 

2. t < 0 
หมายเหตุ 1. �0 เป็นค่าคงท่ี 

2. � ผูว้จิยัเป็นผูก้าํหนด 
3. สมมติฐานแบบทางเดียว จะปฏิเสธสมมติฐาน H0 กต่็อเม่ือ
เง่ือนไขทั้ง 2 ขอ้เป็นจริง หรือ ขอ้ใดขอ้หน่ึงไม่จริง 

 
การทดสอบสมมตฐิานค่าเฉลีย่ 

การทดสอบสมมตฐิานค่าเฉลีย่สําหรับ 1 กลุ่มตัวอย่าง 
เป็นการศึกษาโดยการตรวจสอบวา่คุณลกัษณะใดคุณลกัษณะหน่ึงของขอ้มูลเป็นไปตามท่ีคาดหวงัหรือ

กาํหนดไวห้รือไม่ โดยพิจารณาจากค่าเฉล่ีย คุณลกัษณะ เช่น อาย ุรายได ้ระดบัความพึงพอใจ ฯ ซ่ึงถือวา่เป็นตวั
แปรหน่ึงตวัแปร หรือเรียกไดว้า่ การวเิคราะห์ขอ้มูลแบบ 1 ตวัแปร 

ตวัแปรทีนํ่ามาทดสอบตอ้งเป็นตวัแปรท่ีคาํนวณได ้คือ ระดบัช่วง อตัราส่วน ระดบัเรียงอนัดบั 
ตวัสถิติท่ีใชใ้นการทดสอบ 2 ตวั 
กรณีทราบการกระจาย (�) ของขอ้มูลประชากร ใช ้Z-Test 
กรณีไม่ทราบการกระจาย (�) ของขอ้มูลประชากร แต่ทราบทราบการกระจายของขอ้มูลตวัอยา่ง 
ใช ้T-Test สาํหรับการวจิยัจะใชต้วัน้ี เพราะเป็นการวจิยัจากขอ้มูลตวัอยา่ง 

ตวัอย่าง  
สมมติฐานวจิยั  คนขบัรถแทก็ซ่ีใน กทม. มีรายไดไ้ม่ตํ่ากวา่ 1,000 บาท 
สมมติฐานทางสถิติ H0 : รายไดค้นขบัแทก็ซ่ีไม่ตํ่ากวา่ 1,000 บาท 
   H1 : รายไดค้นขบัแทก็ซ่ีตํ่ากวา่ 1,000 บาท 
กาํหนดเป็นสัญญาลกัษณ์ H0 : μ � 1,000 
   H1 : μ < 1,000 



วธีิการหาค่า T-Test 
1. เปิดไฟล ์DATA11.sav  
2. เลือกเมนู Analyze -> Compare Means -> One – Sample T Test  

 
เลือกตวัแปร One-sample [income] คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Test Variable(s) 
Test Value: พิพม ์1000 

3. คลิกปุ่ม Options  

 
Confidence Interval พิมพ ์95 
คลิกปุ่ม Continue 

4. คลิกปุ่ม OK ไดผ้ลลพัธ์  

 
  



ความหมายของผลลพัธ์ 
 One-Sample Statistics 

N จาํนวนขอ้มูล 
Mean ค่าเฉล่ียของรายได ้
Std. Deviation ค่าส่วนเบ่ียงเบนมาตรฐานของรายได ้ท่ีแสดงการกระจายของขอ้มูล 
Std. Error Mean ค่าความคาดเคล่ือนมาตรฐานของรายได ้

 One-Sample Test 
Test Value = 1000 ค่าท่ีผูท้ดสอบกาํหนดไวใ้นสมมติฐาน 
t, df, Sig.(2-tailed) ค่าท่ีใชใ้นการตดัสินใจวา่จะยอมรับหรือปฏิเสธสมมติฐาน H0 
Mean Difference ผลต่างของค่าเฉล่ียประชากรและค่าเฉล่ียของตวัอยา่ง ค่าติดลบหมายความ

วา่ค่าเฉล่ียตวัอยา่งนอ้ยกวา่ค่าเฉล่ียของประชากร 
95% Confidence ค่าท่ีแสดงขอบเขตบนและขอบเขตล่างของการประมาณค่าผลต่างระหวา่ง

รายไดเ้ฉล่ียตวัอยา่งกบัรายไดเ้ฉล่ียของประชากรท่ีช่วงความเช่ือมัน่ 95% 
 
การตดัสินใจว่าจะยอมรับหรือปฏิเสธสมมตฐิาน H0 จะต้องพจิารณาจาก ค่า t และ Sig.(2-tailed) 
สาํหรับค่า t จะอาศยัตารางสถิตมิาตรฐาน 
สําหรับค่า Sig.(2-tailed) จะพจิารณาตามประเภทของสมมตฐิานทางสถิติ 
กรณีกาํหนดสมมติฐานแบบสองทาง (Two-tails Test) 
 จะปฏิเสธสมมติฐาน H0 เม่ือค่า Sig.(2-tailed) มีค่าน้อยกว่าค่า � ท่ีผูว้จิยักาํหนด 
กรณีกาํหนดสมมติฐานแบบทางเดยีว (One-tails Test) 

 จะปฏิเสธสมมติฐาน H0 เม่ือค่า Sig.(2-tailed) หารด้วย 2 มีค่าน้อยกว่าค่า � ท่ีผูว้ิจยักาํหนด 
 
จากตวัอย่างไดก้าํหนดสมมติฐานแบบทางเดียว 
การตดัสินใจปฏิเสธสมมติฐาน H0 เม่ือค่า Sig.(2-tailed) หารด้วย 2 มีค่าน้อยกว่าค่า � ท่ีผูว้จิยักาํหนดและ 
ค่า t < 0 
H0 : μ � 1,000 
H1 : μ < 1,000 
ผูท้ดสอบกาํหนดช่วงความเช่ือมัน่ 95% จะไดค้่า � = 0.05  ค่า Sig.(2-tailed) ท่ีคาํนวณไดเ้ท่ากบั 0.387 
เน่ืองจากตวัอยา่งเป็นการทดสอบสมมติฐานแบบทางเดียวก่อนท่ีจะคา่ � เปรียบเทียบค่า Sig.(2-tailed)  
ตอ้งนาํ ค่า Sig.(2-tailed) หารด้วย 2 ก่อน ค่าจากตวัอยา่งคือ 0.387/2 = 0.1935 ซ่ึงมีค่ามากค่า � ท่ี 
กาํหนดคือ 0.05 (0.1935 > 0.05) 
ดงัน้ันจึงตดัสินใจ ยอมรับสมมติฐาน H0 : μ � 1,000 
สรุปผลได้ว่า  รายไดเ้ฉล่ียของคนขบัแทก็ซ่ีไม่ตํ่ากวา่ 1,000 บาทท่ีระดบันยัสาํคญั 0.05 

 



การทดสอบสมมตฐิานผลต่างระหว่างค่าเฉลีย่สําหรับ 2 กลุ่มตวัอย่าง ม ี2 กรณี 
เป็นการทดสอบผลต่างระหวา่งค่าเฉล่ียของลกัษณะท่ีสนใจของ 2 กลุ่มตวัอยา่งวา่แตกต่างกนัหรือไม่ 
1. กรณีที ่2 กลุ่มตวัอย่างเป็นอสิระต่อกนั  
2. กรณีที ่2 กลุ่มตวัอย่างเป็นแบบจับคู่  

 
1. กรณีที ่2 กลุ่มตวัอย่างเป็นอสิระต่อกนั 

เป็นการศึกษาเปรียบเทยีบและตรวจสอบวา่คุณลกัษณะใดคุณลกัษณะหน่ึงของข้อมูลระหว่าง 2 กลุ่มมีความ
แตกต่างกนัหรือไม่ และถ้าแตกต่างกนัน้ันแตกต่างกนัอย่างไร โดยพิจารณาจากค่าเฉล่ียของคุณลกัษณะนั้นๆ  

การทดสอบแบบน้ีจดัอยูใ่นประเภทของการวิเคราะห์ขอ้มูลแบบ 2 ตวัแปร (Bivariate data analysis)  
เน่ืองจากการทดสอบจะตอ้งใชต้วัแปร 2 ตวั คือตัวแปรหน่ึงแทนคุณลกัษณะอกีตัวแปรหน่ึงใช้แบ่งกลุ่ม 

ขอ้มูลตวัแปรคุณลกัษณะ ต้องคํานวณได้ คือ ระดบัช่วงและอตัราส่วน 
ขอ้มูลตวัแปรแบ่งกลุ่ม ต้องคาํนวณไม่ได้ คือ Nominal, Ordinal 
 
การทดสอบค่าเฉลีย่ของข้อมูล 2 กลุ่มแบบพาราเมตริก กรณี 2 กลุ่มเป็นอสิระต่อกนั 

ขอ้มูลท่ีจะทดสอบตอ้งมีคุณสมบติัท่ีสามารถใชว้ธีิการการทดสอบแบบพาราเมตริก คือ ข้อมูลหรือ 
ตวัแปรที่ต้องการทดสอบจะตอ้งมีการแจกแจงแบบปกตหิรือใกล้เคยีงแบบปกต ิและสามารถคํานวณได ้ 
คือตวัแปรระดบัช่วงและอตัราส่วน 
ตวัสถิตทิีใ่ช้ทดสอบ 
กรณีทราบการกระจายของข้อมูลของประชากรทั้ง 2 กลุ่ม (ทราบ �1, �2) ใช ้Z-Test 
กรณีไม่ทราบการกระจายของข้อมูลของประชากรทั้ง 2 กลุ่ม (ไม่ทราบ �1, �2) ใช ้T-Test 
ถา้ผูว้จิยัไม่ทราบการกระจายของข้อมูลทั้ง 2 ประชากร และไม่ทราบการกระจายแตกต่างกนัหรือไม่ ให ้
ใช้ข้อมูลตวัอย่างมาทดสอบเพื่อพิจารณาวา่การกระจายของข้อมูลประชากรมคีวามแตกต่างกนัหรือไม่  
โดยกาํหนดสมมติฐาน ดงัน้ี 

H0 : การกระจายขอ้มูลของประชากรทั้ง 2 กลุ่มไม่แตกต่างกนั หรือ H0 : �1 = �2 
H1 : การกระจายขอ้มูลของประชากรทั้ง 2 กลุ่มแตกต่างกนั  หรือ H1 : �1 ≠ σ 2 
ตวัสถิติท่ีใชท้ดสอบคือ F-Test 

ตวัอย่าง ผูว้จิยัตอ้งการทราบวา่ค่าใชจ่้ายแต่ละวนัระหวา่งนกัศึกษา 2 คณะแตกต่างกนัหรือไม่ 
สมมติฐานทางสถิติ H0 : ค่าใชจ่้ายนกัศึกษา 2 คณะไม่แตกต่างกนั  หรือ H0 : μ1 = μ2 

   H1 : ค่าใชจ่้ายนกัศึกษา 2 คณะแตกต่างกนั  หรือ H1 : μ1 ≠  μ2 
1. เปิดไฟล ์DATA12a.sav 
2. เลือกเมนู Analyze -> Compare Means -> Independent Samples T Test 



 
เลือกตวัแปร expenses คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Test Variable(s) 

เลือกตวัแปร faculty    คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Grouping Variable 
3. คลิกปุ่ม Define Groups 

 
Group 1 พิมพ ์ 1 
Group 2 พิมพ ์ 2 
คลิกปุ่ม Continue 

4. คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 



ความหมายของผลลพัธ์ 
 Group Statistics 

N จาํนวนขอ้มูลของแต่ละกลุ่มยอ่ย 
Mean ค่าเฉล่ียของค่าใชจ่้ายแต่ละกลุ่มยอ่ย 
Std. Deviation ค่าส่วนเบ่ียงเบนมาตรฐานของค่าใชจ่้ายแต่ละกลุ่มยอ่ย 
Std. Error Mean ค่าความคาดเคล่ือนมาตรฐานของค่าใชจ่้ายแต่ละกลุ่มยอ่ย 

  
ให้พจิารณา 2 ขั้นตอน 
ขั้นตอนที ่1 ตอ้งทาํการทดสอบการกระจายของขอ้มูลประชากรก่อนวา่แตกต่างกนัหรือไม่ 

ใหพิ้จารณาค่าสถิติจากคอลมัน์ Levene's Test for Equality of Variances  
F ค่าสถิติท่ีคาํนวณไดจ้ากขอ้มูลตวัอยา่งใชเ้ทียบค่าจากตาราง F มาตราฐาน 
Sig. ค่าความน่าจะเป็นในการยอมรับหรือปฏิเสธสมมติฐาน H0 

การทดสอบการกระจายของข้อมูลประชากรก่อนว่าแตกต่างกนัหรือไม่ 
กาํหนดสมมติฐานทางสถิติ 
H0 : การกระจายขอ้มูลของประชากรทั้ง 2 กลุ่มไม่แตกต่างกนั  หรือ H0 : �1 = �2 
H1 : การกระจายขอ้มูลของประชากรทั้ง 2 กลุ่มแตกต่างกนั หรือ H1 : �1 ≠ σ 2 
โดยกาํหนด � = 0.05 
ใหดู้ค่า Sig. ตรงบรรทดั Equal variances assumed 
ค่า Sig. ท่ีคาํนวณไดเ้ท่ากบั 0.336 
จะปฏิเสธสมมติฐาน H0 เม่ือ ค่า Sig. มีค่าน้อยกว่า � ท่ีผูว้จิยักาํหนด 
ค่า Sig. มากกว่า � (0.336 > 0.05) 
ดงัน้ันจึงตดัสินใจ ยอมรับสมมติฐาน H0 : �1 = �2 
สรุปผลได้ว่า  การกระจายข้อมูลของประชากรทั้ง 2 กลุ่มไม่แตกต่าง 

 
ขั้นตอนที ่2 หลงัจากทราบการกระจายของขอ้มูลวา่แตกต่างกนัหรือไม่ ใหพิ้จารณาผลลพัธ์ถดัไป 

ใหพิ้จารณาค่าสถิติจากคอลมัน์ t-test for Equality of Means 
t, df ค่าสถิติท่ีคาํนวณไดจ้ากขอ้มูลตวัอยา่ง 
Sig.(2-tailed) ค่าความน่าจะเป็นในการยอมรับหรือปฏิเสธสมมติฐาน H0 
Mean Difference ค่าผลต่างระหวา่งค่าเฉล่ียทั้ง 2 กลุ่ม 
Std. Error Difference ค่าความคาดเคล่ือนมาตรฐานของค่าผลต่าง 
95% Confidence ค่าท่ีแสดงขอบเขตช่วงความเช่ือมัน่ 95% ของผลต่างค่าเฉล่ีย 

ถา้การกระจายของขอ้มูลไม่แตกต่างกนั (�1= �2) ใหดู้แถว Equal variances assumed 
ถา้การกระจายของขอ้มูลแตกต่างกนั(�1 ≠ σ 2) ใหดู้แถว Equal variances not assumed 
เพื่อใชใ้นการตดัสินใจของสมมติฐานทางสถิติของการวจิยัต่อไป 

 จากขั้นตอนที ่1 ทราบว่าการกระจายข้อมูลของประชากรทั้ง 2 กลุ่มไม่แตกต่างกนั (�1 = �2) 
ให้ดูค่า Sig.(2-tailed) ตรงบรรทดั Equal variances assumed 



ค่า Sig.(2-tailed) ท่ีคาํนวณไดเ้ท่ากบั 0.719 
จะปฏิเสธสมมติฐาน H0 เม่ือ ค่า Sig. มีค่าน้อยกว่า � ท่ีผูว้จิยักาํหนด 
ค่า Sig.(2-tailed) มากกว่า � (0.719 > 0.05) 
ดงัน้ันจึงตดัสินใจ ยอมรับสมมติฐาน H0 : μ1 = μ2 
สรุปผลได้ว่า  ค่าใชจ่้ายของนกัศึกษาทั้ง 2 คณะไม่แตกต่างกนัท่ีระดบันยัสาํคญั 0.05 
สมมตฐิานแบบ 2 ทาง ค่า 95% สามารถสรุปผลได้ว่า ค่าใชจ่้ายของนกัศึกษาทั้ง 2 คณะไม่แตกต่าง 
กนั ตั้งแต่ -39.01 ถึง 27.51 บาท ท่ีช่วงความเช่ือมัน่ 95% 

 
 จากขั้นตอนที ่1 สมมตว่ิาการกระจายข้อมูลของประชากรทั้ง 2 กลุ่มแตกต่างกนั (�1 ≠ σ 2) 

ให้ดูค่า Sig.(2-tailed) ตรงบรรทดั Equal variances not assumed 
ค่า Sig.(2-tailed) ท่ีคาํนวณไดเ้ท่ากบั 0.727 
จะปฏิเสธสมมติฐาน H0 เม่ือ ค่า Sig. มีค่าน้อยกว่า � ท่ีผูว้จิยักาํหนด 
ค่า Sig.(2-tailed) มากกว่า � (0.727 > 0.05) 
ดงัน้ันจึงตดัสินใจ ยอมรับสมมติฐาน H0 : μ1 = μ2 
สรุปผลได้ว่า  ค่าใชจ่้ายของนกัศึกษาทั้ง 2 คณะไม่แตกต่างกนัท่ีระดบันยัสาํคญั 0.05 
สมมตฐิานแบบ 2 ทาง ค่า 95% สามารถสรุปผลได้ว่า ค่าใชจ่้ายของนกัศึกษาทั้ง 2 คณะไม่แตกต่างกนั 
ตั้งแต่ -40.45 ถึง 28.95 บาท ท่ีช่วงความเช่ือมัน่ 95% 
 



การทดสอบค่าเฉลีย่ของข้อมูล 2 กลุ่มแบบน็อนพาราเมตริก กรณี 2 กลุ่มเป็นอสิระต่อกนั 
เป็นขอ้มูลตวัอยา่งท่ีจะนาํมาทดสอบท่ีเลือกจากประชากรท่ีไม่ทราบการแจกแจง หรือทราบการ 
แจกแจงแต่ไม่ใช่การแจกแจงแบบปกติ กลุ่มตวัอย่างที่นํามาทดสอบมจีํานวนน้อย (นอ้ยกวา่ 30)  
ตวัแปรท่ีนาํมาทดสอบตอ้งเป็นขอ้มูลเชิงปริมาณ(คาํนวณได)้และตวัแปรเชิงคุณภาพ(คาํนวณ

ไม่ได)้ 
ตวัสถิติท่ีใชใ้นการทดสอบคือ NPar-Test 

 ตวัอย่าง สมมติฐานทางสถิติ 
H0 : เวลาท่ีใชใ้นการทานอาหารของเพศชายและหญิงไม่แตกต่างกนั หรือ H0 : μ1 = μ2 
H1 : เวลาท่ีใชใ้นการทานอาหารของเพศชายและหญิงไม่แตกต่างกนั หรือ H1 : μ1 ≠  μ2 

1. เปิดไฟล ์DATA12B.sav 
2. เลือกเมนู Analyze -> Nonparametric Test -> 2 Independent Samples 

 
เลือกตวัแปร minute คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Test Variable(s) 

เลือกตวัแปร sex     คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Grouping Variable 
3. คลิกปุ่ม Define Groups 

 
Group 1 พิมพ ์ 1 
Group 2 พิมพ ์ 2 
คลิกปุ่ม Continue 

4. คลิกปุ่ม OK จะไดผ้ลลพัธ์ 



 
ความหมายของผลลพัธ์ 
Ranks 

sex ช่ือตวัแปรท่ีเป็นตวัแบ่งกลุ่มพร้อมแสดงค่า 
N จาํนวนขอ้มูลของแต่ละกลุ่มยอ่ย 
Mean Rank ค่าเฉล่ียของอนัดบัในแต่ละกลุ่ม 
Sum of Ranks ค่าผลรวมของอนัดบัในแต่ละกลุ่ม 

 
Test Statistics 

Mann-Whitney U ค่าสถิติ U ท่ีใชเ้ปรียบเทียบกบัค่าท่ีไดจ้ากตาราง U 
มาตรฐาน 

Wilcoxon W ค่าผลรวมของอนัดบัท่ีมีค่านอ้ยจะใชค้่าน้ีเทียบกบัค่าท่ีได้
จากตาราง W มาตรฐาน 

Z ค่าสถิติ Z ใชแ้ทน U เม่ือขอ้มูลมีจาํนวนมาก 
Asymp. Sig. (2-tailed) ค่าความน่าจะเป็นในการยอมรับสมมติฐาน 
Exact Sig. [2*(1-tailed Sig.)] ค่าความน่าจะเป็นในการยอมรับสมมติฐาน เม่ือขอ้มูลมี

จาํนวนนอ้ย ถา้เป็นการทดสอบแบบทางเดียวจะตอ้งนาํค่าน้ี
ไปหารดว้ย 2 

 



จะปฏิเสธสมมติฐาน H0 เม่ือค่า Asymp. Sig.  หรือ Exact Sig. มีค่าน้อยกว่าค่า � ท่ีผูว้จิยักาํหนด 
จากตวัอยา่งกลุ่มตวัอย่างมขีนาดเลก็จะพิจารณาจากค่า Exact Sig. คือ 0.068 ซ่ึงมีค่ามากกว่า � ท่ี 
กาํหนดไว ้0.05 
การตดัสินไจ  ยอมรับสมมติฐาน H0 : μ1 = μ2 
สรุปผลได้ว่า   เวลาท่ีใชใ้นการทานอาหารของเพศชายและหญิงไม่แตกต่างกนัท่ีระดบันยัสาํคญั 

0.05 
   
2. กรณีที ่2 กลุ่มตวัอย่างเป็นแบบจับคู่ทีม่คีวามสัมพนัธ์กนั 

เป็นการทดสอบความแตกต่างของค่าเฉล่ียระหวา่งกลุ่ม 2 กลุ่มตวัอยา่ง เม่ือขอ้มูลตวัอยา่งท่ีจะใช ้
 ทดสอบมีความสัมพนัธ์กนั  

การทดสอบแบบน้ี จะเป็นการทดสอบความแตกต่างเป็นคู่ๆ โดยแต่ละคู่มีความสัมพนัธ์กนั จึงเรียก 
 การทดสอบน้ีอีกอยา่งหน่ึงคือ การทดสอบความแตกต่างแบบจบัคู่ (Paired Difference Tests) 

การพจิารณาว่ากลุ่มตวัอย่างจะใช้การทดสอบแบบจับคู่ทีม่คีวามสัมพนัธ์กนั ให้พจิารณาจาก 
1. การเปรียบเทียบวธีิการ 2 วธีิกบัขอ้มูลชุดเดียวกนั เช่นผลต่างของคะแนนก่อนอบรมและหลงั

อบรม ขอ้มูลท่ีไดแ้ต่ละคู่มาจากคนเดียวกนั  
2. การเปรียบเทียบขอ้มูล 2 ชุดกบัคุณสมบติัท่ีเหมือนกนั เช่น นาํขา้ราชการท่ีมีระดบัการศึกษา

และมีประสบการณ์ในการทาํงานเหมือนกนัมาเปรียบเทียบเงินเดือนเป็นคู่  
3. การเปรียบเทียบขอ้มูล 2 ประเภทท่ีไดม้าจากแหล่งขอ้มูลเดียวกนั เช่น การเปรียบเทียบ

ยอดขายสินคา้ 2 ยีห่อ้ มาจากร้านคา้ 20 ร้านคา้  
4. การเปรียบเทียบขอ้มูล 2 ประเภทท่ีไดม้าจากช่วงเวลาเดียวกนั เช่น ยอดขายอาหารของ

ร้านอาหาร 2 ร้าน ท่ีไดใ้นแต่ละวนัในเดือนเดียวกนั  
การทดสอบค่าเฉลีย่ของข้อมูล 2 กลุ่ม แบบพาราเมตริก กรณี 2 กลุ่มตวัอย่างมคีวามสัมพนัธ์กนั 

เป็นการทดสอบเม่ือผลต่างของขอ้มูล 2 กลุ่ม มีคุณสมบติัท่ีสามารถทาํการทดสอบแบบพาราเมตริก 
 กล่าวคือ ค่าของผลต่างท่ีไดจ้ากการวดัอยูใ่นระดบัช่วงหรืออตัราส่วน และตอ้งมีการแจกแจงแบบปกติ 
 หรือใกลเ้คียงแบบปกติ 

ตวัสถิติท่ีใชใ้นการทดสอบคือ T-Test 
 ตวัอย่าง ผูว้จิยัตอ้งการทดสอบวา่การอบรมจะทาํใหผู้เ้รียนมีความรู้เพิ่มข้ึนหรือไม่ 

กาํหนดสมมติฐานทางสถิติ 
H0 : คะแนนเฉล่ียก่อนและหลงัการอบรมไม่แตกต่างกนั หรือ H0 : μd = 0 
H1 : คะแนนเฉล่ียก่อนและหลงัการอบรมแตกต่างกนั  หรือ H1 : μd ≠  0 

1. เปิดไฟล ์DATA13A.sav 
2. เลือกเมนู Analyze -> Compare Means -> Paired-Samples T Test 



 
เลือกตวัแปร pre และ post คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์ Paired Variables 



3. คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 
ความหมายของผลลพัธ์ มี 2 ขั้นตอน 
ขั้นตอนที ่1 พิจาราณวา่ขอ้มูล 2 กลุ่มมีความสัมพนัธ์กนัหรือไม่ 
Paired Samples Correlations เป็นส่วนแสดงค่าสถิติสัมประสิทธ์ิสหสัมพนัธ์ 

Correlation ค่าสัมประสิทธ์ิสหสัมพนัธ์ของเปียร์สัน (r) ท่ีแสดงถึงความสัมพนัธ์ของ 2 
กลุ่มท่ีนาํมาทดสอบ ค่าท่ีได ้0.972 แสดงวา่คะแนนก่อนและหลงัการอบรม 
มีความสัมพนัธ์กนัค่อนข้างสูงและไปในทิศทางเดียวกนั 
-1 � r � 1 
บวก ทิศทางเดียวกนั 
ลบ ทิศทางเดียวตรงขา้ม 

Sig. ค่าความน่าจะเป็นท่ีจะใชใ้นการทดสอบสมมติฐานเก่ียวกบัความสัมพนัธ์
ภายใตส้มมติฐานทางสถิติ ดงัน้ี 
H0 : คะแนนทดสอบก่อนและหลงัการอบรมไม่มีความสัมพนัธ์กนั 
H1 : คะแนนทดสอบก่อนและหลงัการอบรมมีความสัมพนัธ์กนั 

ค่า Sig. เท่ากบั 0.000 มีค่าน้อยกว่าค่า � ท่ีผูท้ดสอบกาํหนดคือ 0.05 
การตดัสินใจ   ปฏิเสธสมมติฐาน H0 ยอมรับ H1 
สรุปผลได้ว่า   คะแนนก่อนและหลงัการอบรมมีความสัมพนัธ์กนัทางสถิติท่ีระดบันยัสาํคญั 0.05 
ถา้ขอ้มูล 2 กลุ่มไม่มคีวามสัมพนัธ์กนั ไม่ควรใชก้รณีนีท้ดสอบ และไม่ต้องดูผลลพัธ์ในส่วนถัดไป 



ขั้นตอนที ่2 ขอ้มูล 2 กลุ่มมีความสัมพนัธ์กนั 
Paired Samples Test แสดงค่าสถิติสาํหรับใชใ้นการทดสอบค่าเฉล่ีย 

Mean ค่าเฉล่ียของผลต่างระหวา่งคะแนนก่อนและหลงัการอบรม 
Std. Deviation ค่าส่วนเบ่ียงเบนมาตรฐานของผลต่าง 
Std. Error Mean ค่าความคาดเคล่ือนมาตรฐานของผลต่าง 
95% Confidence ค่าท่ีแสดงขอบเขตช่วงความเช่ือมัน่ 95% ของผลต่างค่าเฉล่ีย 
t, df ค่าสถิติท่ีคาํนวณไดจ้ะใชเ้ทียบกบัค่าจากตารางมาตรฐาน 
Sig.(2-tailed) ค่าความน่าจะเป็นในการยอมรับหรือปฏิเสธสมมติฐาน H0 

ค่า Sig.(2-tailed) เท่ากบั 0.060 มีค่ามากกว่าค่า � ท่ีผูว้จิยักาํหนดคือ 0.05 
การตดัสินใจ   ยอมรับสมมติฐาน H0 
สรุปผลได้ว่า   คะแนนก่อนและหลงัการอบรมไม่แตกต่างกนัท่ีระดบันยัสาํคญั 0.05 

 



การทดสอบค่าเฉลีย่ของข้อมูล 2 กลุ่ม แบบน็อนพาราเมตริก กรณี 2 กลุ่มตวัอย่างมีความสัมพนัธ์กนั 
 ตวัแปรท่ีทดสอบหรือผลต่างของตวัแปรท่ีจะทดสอบมีการวดัเพียงระดบัเรียงอนัดบัเท่านั้น 
 ตวัสถิติท่ีใชใ้นการทดสอบคือ Wilcoxon matched-pairs signed-rank test ซ่ึงเป็น 

การทดสอบเชิงอนัดบั 
ตวัอย่าง ผูว้จิยัตอ้งการทดสอบความแตกต่างของจาํนวนสินคา้ท่ีไม่มีคุณภาพระหวา่งผูท่ี้มีและ 

ไม่มีประสบการณ์ในการทาํงาน 
 กาํหนดสมมติฐานทางสถิติแบบสองทาง 

H0 : จาํนวนสินคา้ท่ีไม่มีคุณภาพท่ีผลิตโดยคนงาน 2 กลุ่มมีจาํนวนเฉล่ียไม่แตกตา่งกนั 
H1 : จาํนวนสินคา้ท่ีไม่มีคุณภาพท่ีผลิตโดยคนงาน 2 กลุ่มมีจาํนวนเฉล่ียแตกต่างกนั 

 กาํหนดเป็นสัญญาลกัษณ์ทางสถิติ 
H0 : μไม่มี  = μมี  
H1 : μไม่มี  ≠  μมี  

 กาํหนดสมมติฐานทางสถิติแบบทางเดียว 
H0 : จาํนวนสินคา้ท่ีไม่มีคุณภาพท่ีผลิตโดยคนงานท่ีไม่มีประสบการณ์มีจาํนวนเฉล่ีย 

  นอ้ยกวา่หรือเท่ากบัท่ีผลิตโดยคนงานท่ีมีประสบการณ์ 
H1 : จาํนวนสินคา้ท่ีไม่มีคุณภาพท่ีผลิตโดยคนงานท่ีไม่มีประสบการณ์มีจาํนวนเฉล่ีย 

  มากกวา่ท่ีผลิตโดยคนงานท่ีมีประสบการณ์ 
กาํหนดเป็นสัญญาลกัษณ์ทางสถิติ 

H0 : μไม่มี  � μมี  
H1 : μไม่มี  > μมี  

 การใช้โปรแกรมวเิคราะห์ข้อมูล 
1. เปิดไฟล ์DATA13B.sav 
2. เลือกเมนู Analyze -> Nonparametric Test -> 2 Related Samples 

 
เลือกตวัแปร exp และ non_exp คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Test Pair(s) List 



3. คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 
ความหมายของผลลพัธ์ 
Wilcoxon Signed Ranks Test เป็นส่วนแสดงค่าสถิติของการจดัอนัดบัของผลต่างระหวา่งตวัแปร 

N แสดงจาํนวนคู่ของผลต่างระหวา่งตวัแปร 
Negative Ranks จาํนวนคู่ของตวัแปรท่ีเป็นตวัลบ นอ้ยกวา่ ตวัตั้ง 
Positive Ranks จาํนวนคู่ของตวัแปรท่ีเป็นตวัลบ มากกวา่ ตวัตั้ง 
Ties จาํนวนคู่ของตวัแปรท่ีเป็นตวัลบ เท่ากบั ตวัตั้ง 
Total จาํนวนคู่ทั้งหมด 

Mean Rank ค่าเฉล่ียของอนัดบัในแต่ละกลุ่ม 
Sum of Ranks ค่าผลรวมของอนัดบัในแต่แต่ละกลุ่ม 
 
Test Statistics เป็นส่วนแสดงค่าสถิติ Wilcoxon ท่ีใชใ้นการทดสอบความแตกต่างของค่าเฉล่ีย 

Z ค่าสถิติ Z ใชแ้ทนค่า Wilcoxon เม่ือขอ้มูลมีจาํนวนมาก ค่า Z จากคู่
ท่ีมีผลต่างเป็นลบ จะใชค้่าน้ีสาํหรับการสรุปผลท่ีตอ้งอาศยัตาราง
สถิติมาตรฐานของ Z 

Asymp. Sig. (2-tailed) ค่าความน่าจะเป็นในการยอมรับหรือปฏิเสธสมมติฐาน โดยไม่
ตอ้งใชอ้าศยัตารางสถิติมาตรฐาน 

 



การสรุปผล 
กรณีทีก่าํหนดสมมตฐิานแบบสองทาง  H0 : μไม่มี  = μมี  
      H1 : μไม่มี  ≠  μมี  
      เม่ือกาํหนด � เป็น 0.05 
จะปฏิเสธสมมติฐาน H0 เม่ือ ค่า Asymp. Sig. มีค่าน้อยกว่า � ท่ีผูว้จิยักาํหนด 
จากตวัอยา่ง ค่า Asymp. Sig. เท่ากบั 0.005 มีค่าน้อยกว่า � ท่ีกาํหนดไวคื้อ 0.05 
การตดัสินใจ ปฏิเสธสมมติฐาน H0 : μไม่มี  = μมี ยอมรับ H1 : μไม่มี  ≠  μมี  
สรุปผลได้ว่า จาํนวนสินคา้ท่ีไม่มีคุณภาพท่ีผลิตโดยคนงาน 2 กลุ่มมีจาํนวนเฉล่ียแตกต่างกนั 
 
กรณีทีก่าํหนดสมมตฐิานแบบทางเดยีว H0 : μไม่มี  � μมี  
      H1 : μไม่มี  > μมี  
      เม่ือกาํหนด � เป็น 0.05 
จะปฏิเสธสมมติฐาน H0 เม่ือ ค่า Asymp. Sig. หารด้วย 2 มีค่าน้อยกว่า � ท่ีผูว้จิยักาํหนด 
จากตวัอยา่ง ค่า Asymp. Sig. เท่ากบั 0.005/2 = 0.0025 มีค่าน้อยกว่า � ท่ีกาํหนดไวคื้อ 0.05 
การตดัสินใจ ปฏิเสธสมมติฐาน H0 : μไม่มี  = μมี ยอมรับ H1 : μไม่มี  ≠  μมี  
สรุปผลได้ว่า จาํนวนสินคา้ท่ีไม่มีคุณภาพ ซ่ึงผลิตโดยคนงานท่ีไม่มีประสบการณ์จะมีจาํนวน 
   มากกวา่ผูท่ี้มีประสบการณ์ท่ีระดบันยัสาํคญั 0.05 



การทดสอบค่าเฉลีย่สําหรับหลายกลุ่มตวัอย่าง โดยวเิคราะห์ความแปรปรวน 
เป็นการศึกษาเปรียบเทียบและตรวจสอบวา่คุณลกัษณะใดคุณลกัษณะหน่ึงของขอ้มูลตั้งแต่ 3 กลุ่มข้ึนไปมี

ความแตกต่างกนัหรือไม่ และถา้แตกต่างกนันั้นแตกต่างกนัอยา่งไร โดยพิจารณาจกค่าเฉล่ียของคุณลกัษณะนั้นๆ 
ตวัสถิติท่ีใชใ้นการทดสอบความแตกต่างระหวา่งค่าเฉล่ียสาํหรับหลายกลุ่มตวัอยา่งคือ การวเิคราะห์ความ

แปรปรวน (Analysis of Variances : ANOVA) 
การวเิคราะห์ความแปรปรวน หรือนิยมเรียกยอ่ๆ วา่ ANOVA เป็นวถีิทางสถิติวธีิหน่ึงท่ีใชใ้นการศึกษาหา

ความสัมพนัธ์ระหวา่งตวัแปร 2 ประเภท คือตวัแปรตาม (Dependent) และตวัแปรอสิระ (Independent) โดยใช้ตวั
แปรอสิระเป็นตัวแบ่งข้อมูลออกเป็นกลุ่มๆ เพื่อทดสอบวา่ในแต่ละกลุ่มทีแ่ตกต่างกนันั้นจะทาํให้ค่าเฉลีย่ของตวั
แปรตามแตกต่างกนัหรือไม่ บางคร้ังอาจเรียกตวัแปรอิสระวา่ ปัจจยั (Factor) 
ประเภทของการวเิคราะห์ความแปรปรวน 
1. การวเิคราะห์ความแปรปรวนแบบจําแนกทางเดยีว (One-Way ANOVA) 

เป็นการวเิคราะห์ความแปรปรวนท่ีใชก้บัขอ้มูลท่ีไดจ้ากการจาํแนกหรือแบ่งกลุ่มโดยใชห้ลกัเกณฑแ์บบเดียว
หรือปัจจยัเดียว 
2. การวเิคราะห์ความแปรปรวนแบบจําแนกสองทาง (Two-Way ANOVA) 

เป็นการวเิคราะห์ความแปรปรวนท่ีใชก้บัขอ้มูลท่ีไดจ้ากการจาํแนกหรือแบ่งกลุ่มโดยใชห้ลกัเกณฑส์องแบบ
หรือสองปัจจยั 
3.การวเิคราะห์ความแปรปรวนแบบจําแนกหลายทาง (Multi-Way ANOVA) 

เป็นการวเิคราะห์ความแปรปรวนท่ีใชก้บัขอ้มูลท่ีไดจ้ากการจาํแนกหรือแบ่งกลุ่มโดยใชห้ลกัเกณฑต์ั้งแต่สาม
แบบเดียวหรือสามปัจจยัข้ึนไป 
วธีิการวเิคราะห์ความแปรปรวนแบ่งได้ 2 วธีิ 

1. การวเิคราะห์ความแปรปรวนโดยวธีิพาราเมตริก  
2. การวเิคราะห์ความแปรปรวนโดยวธีิน็อนพาราเมตริก  

 
การวเิคราะห์ความแปรปรวนจําแนกทางเดยีวแบบพาราเมตริก 

คุณลกัษณะของขอ้มูลมีขอ้กาํหนดดงัน้ี 
1. ขอ้มูลแต่ละกลุ่มยอ่ยจะตอ้งมาจากประชากรท่ีมีการกระจายหรือความแปรปรวนไม่แตกต่างกนัทางสถิติ  
2. ขอ้มูลแต่ละกลุ่มยอ่ยท่ีเลือกมาทดสอบมาจากประชากรที่มีการแจกแจงแบบปกติ  
3. ตวัอยา่งท่ีเลือกมาแต่ละกลุ่มควรจะตอ้งเป็นอิสระต่อกนั  
ตวัอย่าง ผูว้จิยัตอ้งการทดสอบราคาสินคา้ชนิดหน่ึงท่ีผลิตจากผูผ้ลิตท่ีใชย้ีห่อ้แตกต่างกนัจาํนวน 4 ยีห่อ้วา่มี
ราคาจาํหน่ายตามร้านต่างๆ แตกต่างกนัหรือไม่ 
ยีห้่อ เป็นตวัแปรอิสระท่ีใชใ้นการแบ่งกลุ่ม 
ราคา เป็นตวัแปรตามท่ีจะหาค่าเฉล่ียแตกต่างกนัหรือไม่ 
กาํหนดสมมติฐานทางสถิติ 
H0 : ราคาเฉล่ียของสินคา้แต่ละยีห่อ้ไม่แตกต่างกนั หรือ H0 : μ1 = μ2 = μ3 = μ4 
H1 : ราคาเฉล่ียของสินคา้แต่ละยีห่อ้แตกต่างกนั      หรือ H1 : μi ≠  μj สาํหรับ i ≠  j 



ถา้ยอมรับสมมติฐานจะสรุปไดว้า่สินค่า 4 ยีห่อ้ ราคาเฉล่ียไม่แตกต่างกนั แต่ถา้ปฏิเสธสมมติฐาน แสดงวา่มี
อยา่งนอ้ย 2 ยีห่อ้ราคาเฉล่ียแตกต่างกนั แต่ไม่สามารถบอกไดว้า่ยีห่อ้ไหนบา้งท่ีแตกต่างกนั ถา้ตอ้งการวา่มี 2 
ยีห่อ้ใดบา้งท่ีมีราคาเฉล่ียแตกต่างกนั จะตอ้งดาํเนินการทดสอบต่อไปโดยใชว้ธีิการเปรียบเทียบแบบพหุคูณ 
(Multiple Comparison Test) 
การใช้โปรแกรมทดสอบค่าเฉลีย่หลายกลุ่มแบบพาราเมตริก ตอ้งดาํเนินการ 2 ขั้นตอน 
1. การใชโ้ปรแกรมตรวจสอบคุณลกัษณะของขอ้มูล  
2. การใชโ้ปรแกรมวเิคราะห์ความแปรปรวนแบบจาํแนกทางเดียวแบบพาราเมตริก  
การใช้โปรแกรมตรวจสอบคุณสมบัตขิองข้อมูล 
1. เปิดไฟล ์DATA14A.sav  
2. เลือกเมนู Analyze -> Descriptive Statistics -> Explore  

 
เลือกตวัแปร price คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Dependent List 

เลือกตวัแปร brand คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Factor List 
3. คลิกปุ่ม Plots  

 
เลือก Normality plots with test เพื่อตรวจสอบขอ้มูลมีการแจกแจงแบบปกติหรือไม่ 
เลือก Power estimation เพื่อตรวจสอบขอ้กาํหนดของความแปรปรวน 

4. คลิดปุ่ม OK จะไดผ้ลลพัธ์  



 
เป็นค่าสถิติของ Kolmogorov-Smirnov และ Shapiro-Wilk พร้อมค่าความน่าจะเป็น Sig. 
สาํหรับทดสอบค่าตวัแปร price แต่ละกลุ่มมีการแจกแจงแบบปกติหรือไม่ภายใตส้มมติฐานทางสถิติ 
H0 : ขอ้มูลท่ีนาํมาทดสอบแต่ละกลุ่มมีการแจกแจงไม่ใช่แบบปกติ 
H1 : ขอ้มูลท่ีนาํมาทดสอบแต่ละกลุ่มมีการแจกแจงแบบปกติ 
ค่าสถิติ Shapiro-Wilk จะแสดงเม่ือขอ้มูลนอ้ยกวา่หรือเท่ากบั 50  
การตดัสินจะปฏิเสธสมมติฐาน H0 ถ้าค่า Sig. น้อยกว่าค่า � ทีก่าํหนด 
จากผลลพัธ์ท่ีได ้ค่า Sig. เท่ากบั . แสดงวา่สรุปไม่ได ้
ค่า Sig. ของ  Kolmogorov-Smirnov มากกว่าค่า  � 
ค่า Sig. ของ Shapiro-Wilk มากกว่าค่า  � 
การตดัสินใจ ยอมรับสมมติฐาน H0 ทั้งของ Kolmogorov-Smirnov และ Shapiro-Wilk 
สรุปผลได้ว่า ค่าตวัแปร price ในยีห่อ้ 1, 2 และ 4 มีการแจกแจงแบบปกติท่ีระดบันยัสาํคญั 0.05 

       ส่วนยีห่อ้ท่ี 3 ยงัสรุปไม่ได ้
 ข้อสังเกต ค่าความน่าจะเป็นของกลุ่ม 3 โปรแกรมไม่คาํนวณออกมา เพราะจาํนวนขอ้มูลในกลุ่มน้ีมี
จาํนวนนอ้ยเกินไป (นอ้ยกวา่ 5) ดงันั้นผู้วจิัยต้องพจิารณาว่าในกลุ่ม 3 ควรจะตดัออกไปจากการวิเคราะห์เลยหรือ
เพิม่จํานวนข้อมูลในกลุ่มนีใ้ห้มากขึน้ 

  
 เป็นค่าสถิติ Levene Statistic พร้อมค่าความน่าจะเป็น Sig. ท่ีคาํนวณภายใตเ้ง่ือนไขต่างๆ ปกติจะใชค้่า
ความน่าจะเป็นท่ีคาํนวณจากค่าเฉล่ียพ้ืน (Based on Mean) เพื่อใชใ้นการทดสอบการกระจายของขอ้มูลแต่ละกลุ่ม
ในรูปของความแปรปรวนวา่แต่ละกลุ่มมีความแตกต่างกนัหรือไม่ภายใตส้มมติฐานทางสถิติ 
 H0 : ขอ้มูลท่ีนาํมาทดสอบแต่ละกลุ่มมีการกระจายไม่แตกต่างกนั 
 H1 : ขอ้มูลท่ีนาํมาทดสอบแต่ละกลุ่มมีการกระจายแตกต่างกนั 

การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Sig. น้อยกว่าค่า � ทีก่าํหนด 
ค่า Sig. ท่ีไดจ้าก Based on Mean มีค่ามากกว่าค่า � 
การตดัสินใจ ยอมรับสมมติฐาน H0 



สรุปผลได้ว่า ค่าตวัแปร price ในแต่ละกลุ่มมีการกระจายไม่แตกต่างกนั 
 

 
แสดงกราฟแบบ Normal Q-Q Plot สาํหรับพิจารณาค่าตวัแปร price แต่ละกลุ่มมีการแจกแจงแบบปกติ 
การพจิารณากราฟทีไ่ด้ 

จะพิจารณาจากจุดต่างๆ ท่ีเกิดข้ึนเทียบกบักราฟเส้นตรง กล่าวคือถา้จุดอยูใ่กล้ๆ  บริเวณกราฟ
เส้นตรงมาก แสดงวา่ขอ้มูลมีการแจกแจงใกลเ้คียงแบบปกติ ถา้จุดอยูห่่างจากกราฟเส้นตรงมาก แสดง
วา่ขอ้มูลมีการแจกแจงไม่ใช่แบบปกติ 

จากตวัอยา่ง ค่าตวัแปร price แต่ละกลุ่มมีการแจกแจงแบบปกติ 
  



  
แสดงกราฟแบบ DetrendedNormal Q-Q Plot สาํหรับพิจารณาค่าตวัแปร price แต่ละกลุ่มมีการแจกแจง
แบบปกติ 
การพจิารณากราฟทีไ่ด้ 

จะพิจารณาจากจุดต่างๆท่ีเกิดข้ึนเทียบกบัเส้นตรง กล่าวคือถา้จุดอยูใ่กล้ๆ  บริเวณเส้นตรงมาก 
แสดงวา่ขอ้มูลมีการแจกแจงใกลเ้คียงแบบปกติ ถา้จุดอยูห่่างจากเส้นตรงมาก แสดงวา่ขอ้มูลมีการแจก
แจงไม่ใช่แบบปกติ 

  
 แสดงกราฟแบบ Box-Plot เพื่อใชใ้นการพิจารณาคุณลกัษณะของขอ้มูล 2 ลกัษณะ 

1. พิจารณาเส้นกลางของ Box ซ่ึงกคื็อค่า Median ใชเ้พื่อการพิจารณาความเบข้องกราฟโคง้ความถ่ีแต่
ละกลุ่ม ถา้เส้นแกนกลางอยูใ่กลเ้คียงก่ึงกลาง Box แสดงวา่กราฟมีลกัษณะไม่เบ ้

2. ส่วนความสูงของ Box จะเป็นความสูงท่ีแทนค่าเฉล่ียของขอ้มูลแต่ละกลุ่ม ถา้ความสูงใกลเ้คียงกนั 
แสดงวา่ค่าเฉล่ียในแต่ละกลุ่มใกลเ้คียงกนั 



 
 

 
แสดงกราฟแบบ Spread vs. Level Plot เพื่อเปรียบเทียบการกระจายของขอ้มูลแต่ละกลุ่ม 
การพิจารณากราฟท่ีได ้

พิจารณาจากจุดต่างๆ ท่ีเกิดข้ึนในกราฟแต่ละกลุ่ม พบวา่กลุ่ม 1, 2 และ 3 มีการกระจายใกลเ้คียงกนั 
 ค่า Slop ถา้ต่างจาก 0 มากเท่าไรกแ็สดงวา่ถึงความแตกต่างของการกระจายแต่ละกลุ่มมากเท่านั้น 
 

การใช้โปรแกรมวเิคราะห์ความแปรปรวนแบบจําแนกทางเดยีวแบบพาราเมตริก 
1. เลือกเมนู Analyze -> Compare Means -> One-Way ANOVA  

 



เลือกตวัแปร price คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Dependent List 

เลือกตวัแปร brand คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Factor 
2. คลิกปุ่ม Options  

 
เลือก Descriptive ใหแ้สดงค่าสถิติเบ้ืองตน้ของแต่ละกลุ่ม 

 เลือก Homogeneity of variance test ใหค้่าสถิติท่ีใชท้ดสอบการกระจายของแต่ละกลุ่ม 
 เลือก Means plot ใหแ้สดงกราฟเปรียบเทียบค่าเฉล่ียในแต่ละกลุ่ม 
 คลิกปุ่ม Continue 

3. คลิกปุ่ม Post Hoc ถา้ตอ้งการค่าสถิติท่ีใชใ้นการทดสอบจบัคู่พหุคูณ  

 
กรณีความแปรปรวนไม่ต่างกนัเลือก Scheffe 
กรณีความแปรปรวนต่างกนัเลือก Tamhane’s T2 
Significance level กาํหนดค่า � ตามท่ีผูว้จิยัตอ้งการ 
คลิกปุ่ม Continue 

4. คลิกปุ่ม OK จะไดผ้ลลพัธ์  



 
เป็นค่าสถิติ Levene Statistic พร้อมค่าความน่าจะเป็น Sig. เพื่อตรวจสอบดูวา่ขอ้มูลท่ีนาํมาใชน้ี้สามารถ

ใชว้ธีิวเิคราะห์ความแปรปรวนแบบพาราเมตริกไดห้รือไม่ โดยพิจารณาจากสมมติฐานทางสถิติ 
 H0 : ความแปรปรวนของราคาสินคา้ในแต่ละกลุ่มไม่แตกต่างกนั 
 H1 : มีอยา่งนอ้ย 2 กลุ่มท่ีราคาสินคา้มีความแปรปรวนต่างกนั 

การตดัสินจะปฏิเสธสมมติฐาน H0 ถ้าค่า Sig. น้อยกว่าค่า � ทีก่าํหนด 
ค่า Sig. ท่ีได ้มีค่ามากกว่าค่า � 
การตดัสินใจ ยอมรับสมมติฐาน H0 
สรุปผลได้ว่า ความแปรปรวนของราคาสินคา้ไม่แต่ต่างกนัท่ีระดบันยัสาํคญั 0.05 
 

 
เป็นค่าสถิติต่างๆ ของการวเิคราะห์ความแปรปรวน เพื่อใชท้ดสอบสมมติฐาน 
H0 : ราคาเฉล่ียของสินคา้แต่ละยีห่อ้ไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 ยีห่อ้ท่ีมีราคาเฉล่ียแตกต่างกนั 
การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Sig. น้อยกว่าค่า � ทีก่าํหนด 
ค่า Sig. ท่ีได ้มีค่าน้อยกว่าค่า � 
การตดัสินใจ ปฏิเสธสมมติฐาน H0 ยอมรับสมมติฐาน H1 
สรุปผลได้ว่า มีสินคา้อยา่งนอ้ย 2 ยีห่อ้ท่ีมีราคาเฉล่ียแตกต่างกนัท่ีระดบันยัสาํคญั 0.05 
 



ถา้มีการปฏิเสธสมมติฐาน H0 ใหพิ้จารณา
ต่อ

 
แสดงค่าสถิติสาํหรับทดสอบความแตกต่างของค่าเฉล่ียแบบจบัคู่ (Multiple Comparison) 
ค่าของตวัทดสอบ Scheffe ใชส้าํหรับกรณีความแปรปรวนไม่แตกต่างกนั 
ค่าของตวัทดสอบ Tamhaneใชส้าํหรับกรณีความแปรปรวนแตกต่างกนั 
การทดสอบค่าเฉล่ียจะพิจารณาจากค่า Sig. ภายใตส้มมติฐานทางสถิติ 
H0 : ราคาเฉล่ียของราคาสินคา้ 2 ยีห่อ้ท่ีกาํลงัพิจารณาไม่แตกต่างกนั  
H1 : ราคาเฉล่ียของราคาสินคา้ 2 ยีห่อ้ท่ีกาํลงัพิจารณาแตกต่างกนั  
จากตารางผลลพัธ์ ยกตวัอยา่งการจบัคู่ระหวา่ง กลุ่ม 2 กบักลุ่มอ่ืนๆ  

 
การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Sig. น้อยกว่าค่า � ทีก่าํหนด (0.05) 
ค่าความน่าจะเป็นในการยอมรับสมมติฐาน Sig. ของกลุ่มท่ี 2 สาํหรับทดสอบกบักลุ่มอ่ืนๆ ดงัน้ี 

กบักลุ่ม 1 เท่ากบั 0.233 มีค่ามากกว่าค่า � จึงยอมรับสมมติฐาน H0 
กบักลุ่ม 3 เท่ากบั 0.042 มีค่าน้อยกว่าค่า � จึงปฏิเสธสมมติฐาน H0 
กบักลุ่ม 4 เท่ากบั 0.001 มีค่าน้อยกว่าค่า � จึงปฏิเสธสมมติฐาน H0 



สรุปผลได้ว่า กลุ่มท่ี 2 ราคาเฉล่ียไม่แตกต่างกบักลุ่มท่ี 1 แต่แตกต่างกบักลุ่มท่ี 3 และ 4 
ให้ทดสอบการจับคู่ทีเ่หลอืให้ครบ 
 

 
ค่าสถิติ Scheffe ใชส้รุปความแตกต่างของราคาเฉลี่ย โดยจดักลุ่มยีห่อ้ท่ีมีราคาเฉล่ียอยูใ่นกลุ่มเดียวกนั 
การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Sig. น้อยกว่าค่า � ทีก่าํหนด 
ค่า Sig. ท่ีได ้มีค่ามากกว่าค่า � (0.274 > 0.05) 
การตดัสินใจ ยอมรับสมมติฐาน H0 
สรุปผลได้ว่า ยีห่อ้ท่ี 1 และ ยีห่อ้ท่ี 2 มีราคาเฉล่ียไม่แตกต่างกนั 

  
การวเิคราะห์ความแปรปรวนจํานวนทางเดยีวแบบน็อนพาราเมตริก 

เป็นการทดสอบเก่ียวกบัค่าเฉล่ียของขอ้มูลตั้งแต่ 3 กลุ่มข้ึนไป ท่ีไม่สามารถใชว้ธีิวิเคราะห์ความแปรปรวน
แบบพาราเมตริก 

ขอ้มูลท่ีจะนาํมาวเิคราะห์ควรเป็นขอ้มูลท่ีมีการวดัตั้งแต่ระดบัเรียงอนัดบัข้ึนไป 
สามารถจาํแนกได ้2 วธีิ ตามคุณลกัษณะของขอ้มูล คือ กรณีท่ีขอ้มูลแต่ละกลุ่มเป็นอิสระต่อกนั และกรณีท่ี

ขอ้มูลแต่ละกลุ่มมีความสัมพนัธ์ 
ตวัอย่าง จะใชข้อ้มูลท่ีใชท้ดสอบราคาของสินคา้ 4 ยีห่อ้ โดยสมมติวา่ท่ีไม่สามารถใชว้ธีิวเิคราะห์ความแปรปรวน
แบบพาราเมตริกได ้โดยกาํหนดสมมติฐานทางสถิติดงัน้ี 

H0 : อนัดบัเฉล่ียของราคาสินคา้แต่ละยีห่อ้ไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 ยีห่อ้ท่ีมีอนัดบัเฉล่ียของราคาแตกต่างกนั 
ถา้ยอมรับสมมติฐานสามารถสรุปไดว้า่อนัดบัเฉล่ียของราคาสินคา้แต่ละยีห่อ้ไม่แตกต่างกนั แต่ถา้ปฏิเสธ

สมมติฐานแสดงวา่มีอยา่งนอ้ย 2 ยีห่อ้ท่ีมีอนัดบัเฉล่ียของราคาแตกต่างกนั ถา้ตอ้งการทราบวา่ 2 ยีห่อ้ใดท่ีมีราคา
แตกต่างกนักส็ามารถทาํไดโ้ดยใชว้ธีิจบัคู่ท่ีละคู่ท่ีเป็นไปไดโ้ดยใชว้ธีิการทดสอบแบบน็อนพาราเมตริกสาํหรับ
ขอ้มูล 2 กลุ่มท่ีเป็นอิสระต่อกนัของ Mann-Whiteney U 
 

การใช้โปรแกรมวเิคราะห์ความแปรปรวนแบบจําแนกทางเดยีวแบบน็อนพาราเมตริก 



1. เปิดไฟล ์DATA14A.sav  
2. เลือกเมนู Analyze -> Nonparametric -> K Independent Samples  

 
เลือกตวัแปร price คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Test Variable List 

เลือกตวัแปร brand คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Grouping Variable 
3. คลิกปุ่ม Define Range  

 
Minimum พิมพ ์1 
Maximum พิมพ ์4 
คลิกปุ่มContinue 

4. คลิกปุ่ม Options  

 
เลือก Descriptive 
คลิกปุ่มContinue 



5. คลิกปุ่ม OK จะไดผ้ลลพัธ์  

 
Test Statistics แสดงค่าสถิติ สาํหรับทดสอบความแตกต่างของค่าเฉล่ียของอนัดบัในแต่ละกลุ่มโดยค่าสถิติ

ของ Kruskal-Wallis ซ่ึงแปลงมาอยูใ่นรูปของ Chi-Square : �2 และค่าความน่าจะเป็น Asymp. Sig. ภายใต้
สมมติฐาน  

H0 : อนัดบัเฉล่ียของราคาสินคา้แต่ละยีห่อ้ไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 ยีห่อ้ท่ีมีอนัดบัเฉล่ียของราคาแตกต่างกนั 
การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Asymp. Sig. น้อยกว่าค่า � ทีผู้่วจิัยกาํหนด 
ค่า Asymp. Sig. ท่ีได ้มีค่าน้อยกว่าค่า � (0.001 < 0.05) 
การตดัสินใจ ปฏิเสธสมมติฐาน H0 ยอมรับสมมติฐาน H1 
สรุปผลได้ว่า ความนิยมต่อสินคา้ 4 ยีห่อ้ของผูบ้ริโภคมีสามนิยมแตกต่างกนัอยา่งนอ้ย 2 ยีห่อ้ท่ีระดบั
นยัสาํคญั 0.05 
 

 



การทดสอบค่าเฉลีย่สําหรับหลายกลุ่มตวัอย่าง โดยการวเิคราะห์ความแปรปรวนแบบสองทาง 
การทดสอบค่าเฉล่ียของขอ้มูลท่ีไดจ้ากกลุ่มตวัอยา่งตั้งแต่ 3 กลุ่มตวัอยา่งข้ึนไป เม่ือมีการจาํแนกหรือ

แบ่งกลุ่มขอ้มูลโดยใชห้ลกัเกณฑส์องแบบหรือสองปัจจยั จะเป็นการทดสอบวา่การแบ่งกลุ่มดงักล่าวมีผลกระทบ
ต่อค่าเฉล่ียของคุณลกัษณะท่ีสนใจหรือไม่ 
ข้อกาํหนดของการวเิคราะห์ความแปรปรวนแบบจําแนก 2 ทางด้วยวธีิการพาราเมตริกจะข้ึนอยูก่บัลกัษณะของ
ข้อมูลดงัน้ี 

1. ขอ้มูลแต่ละกลุ่มยอ่ยจะตอ้งมาจากประชากรท่ีมีการกระจายหรือความแปรปรวนไม่แตกต่างกนัทางสถิติ  
(�1

2 =  �2
2 = �3

2   … �n
2 ) 

2. ขอ้มูลในแต่ละกลุ่มยอ่ยท่ีเลือกมาทดสอบควรมาจากประชากรที่มีการแจงแจงแบบปกติ  
3. ตวัอยา่งท่ีมาแต่ละกลุ่มควรจะตอ้งเป็นอิสระต่อกนั  

การวเิคราะห์ข้อมูล 
จะเป็นการวเิคราะห์เพื่อทดสอบผลกระทบของตวัแปรอิสระหรือปัจจยัต่างๆ จาํแนกได ้2 แบบ 
1. สมมติฐานสาํหรับการทดสอบผลกระทบของแต่ละปัจจยั  
2. สมมติฐานสาํหรับการทดสอบผลกระทบร่วมของทั้ง 2 ปัจจยั  

1. สมมตฐิานสําหรับการทดสอบผลกระทบของแต่ละปัจจัย 
เป็นการทดสอบความแตกต่างความแตกต่างของระดบัต่างๆ ในแต่ละปัจจยัโดยจาํแนกได ้2 สมมติฐานตาม
จาํนวนปัจจยั 
1. H0 : ไม่มีความแตกต่างระหวา่งระดบัต่างๆ ของปัจจยัท่ี 1  

H1 : มีอยา่งนอ้ย 2 ระดบัของปัจจยัท่ี 1 ท่ีมีความแตกต่างกนั 
2. H0 : ไม่มีความแตกต่างระหวา่งระดบัต่างๆ ของปัจจยัท่ี 2  

H1 : มีอยา่งนอ้ย 2 ระดบัของปัจจยัท่ี 2 ท่ีมีความแตกต่างกนั 
เน่ืองจากการทดสอบจะพิจารณาในแง่ของค่าเฉล่ียดงันั้นสมมติฐานทางสถิติอาจกาํหนดไดด้งัน้ี 
1. H0 : ค่าเฉล่ียของประชากรแต่ละกลุ่มท่ีจาํแนกโดยปัจจยัหรือตวัแปรท่ี 1 ไม่แตกต่างกนั  

H1 : มีอยา่งนอ้ย 2 กลุ่มประชากรท่ีมีค่าเฉล่ียแตกต่างกนั 
2. H0 : ค่าเฉล่ียของประชากรแต่ละกลุ่มท่ีจาํแนกโดยปัจจยัหรือตวัแปรท่ี 2 ไม่แตกต่างกนั  

H1 : มีอยา่งนอ้ย 2 กลุ่มประชากรท่ีมีค่าเฉล่ียแตกต่างกนั 
หรือกาํหนดเป็นสัญญาลกัษณ์ทางสถิติดงัน้ี 
ปัจจยัท่ี 1 H0 : μ1 = μ2 = μ3 = …μm 

  H1 : μi ≠  μj (i ≠  j) 
ปัจจยัท่ี 2 H0 : μ1 = μ2 = μ3 = …μn 

  H1 : μi ≠  μj (i ≠  j) 



2. สมมตฐิานสําหรับการทดสอบผลกระทบร่วมของทั้ง 2 ปัจจัย 
เป็นการทดสอบวา่ปัจจยัทั้ง 2 มีผลกระทบร่วมกนัหรือไม่จาํแนกได ้2 สมมติฐานดงัน้ี 
1. H0 : ไม่มีผลกระทบร่วมระหวา่งปัจจยั (ตวัแปร) ทั้ง 2  

H1 : มีผลกระทบร่วมระหวา่งปัจจยั (ตวัแปร) ทั้ง 2 
ถา้ปฏิเสธสมมติฐาน H0 ตอ้งมีการทดสอบสมมติฐานต่อเน่ืองอีก 1 สมมติฐาน 

2. H0 : ค่าเฉล่ียของประชากรแต่ละกลุ่มในทุกๆ ระดบั(ของแต่ละช่อง) ไม่แตกต่างกนั  
H1 : มีอยา่งนอ้ย 2 กลุ่มประชากรท่ีมีค่าเฉล่ียแตกต่างกนั 

หรือกาํหนดเป็นสัญญาลกัษณ์ทางสถิติดงัน้ี 
H0 : μ11. = μ12. = μ13. = …μmn. 

 H1 : μijk ≠  μlmn (ijk ≠  lmm) 
ตวัอย่าง ผูว้จิยัตอ้งการศึกษาค่าใชจ่้ายต่อวนัของประชากรซ่ึงจาํแนกตาม อาชีพ และภาค โดยทาํการสาํรวจ

ทุกอาชีพ และทุกจงัหวดัในแต่ละภาค 
การวเิคราะห์ข้อมูลจะใช้การวเิคราะห์ความแปรปรวนแบบจําแนก 2 ทางด้วยวธีิการพาราเมตริก ภายใตปั้จจยั

หรือตวัแปรอิสระ อาชีพ และภาค เป็นปัจจยัคงท่ี สามารถกาํหนดสมมติฐานสาํหรับการทดสอบได ้4 สมมติฐาน 
1. สาํหรับตวัแบบดา้นแถว คือ อาชีพ ซ่ึงจาํแนกได ้3 กลุ่มอาชีพ  

H0 : ค่าใชจ่้ายเฉล่ียของประชาชนแต่ละกลุ่มอาชีพไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 กลุ่มอาชีพท่ีค่าใชจ่้ายเฉล่ียของประชาชนแตกต่างกนั 

2. สาํหรับตวัแบบดา้นคอลมัน์ คือ ภาค ซ่ึงจาํแนกได ้4 ภาค  
H0 : ค่าใชจ่้ายเฉล่ียของประชาชนแต่ละภาคไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 ภาคท่ีค่าใชจ่้ายเฉล่ียของประชาชนแตกต่างกนั 

3. สาํหรับผลกระทบร่วมจากทั้ง 2 ตวัแปร คือ อาชีพ และ ภาค  
H0 : ไม่มีผลกระทบร่วมระหวา่งกลุ่มอาชีพและภาคต่อค่าใชจ่้ายเฉล่ีย 
H1 : มีผลกระทบร่วมระหวา่งกลุ่มอาชีพและภาคต่อค่าใชจ่้ายเฉล่ีย 
ถ้าปฏิเสธสมมติฐาน H0 แสดงวา่อาชีพและภาคมีผลกระทบต่อค่าใชจ่้าย สามารถท่ีจะทดสอบความ
แตกต่างของค่าใชจ่้ายเฉล่ียในส่วนต่างๆ แต่ละช่องภายใตส้มมติฐานน้ี 

4. สาํหรับผลกระทบจากทั้ง 2 ตวัแปร คือ อาชีพ และ ภาค  
H0 : ค่าใชจ่้ายเฉล่ียของประชาชนแต่ละภาคและแต่ละอาชีพไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 กลุ่มภาคและอาชีพท่ีค่าใชจ่้ายเฉล่ียของประชาชนแตกต่างกนั 

 



การใช้โปรแกรมเพือ่ทดสอบความแตกต่างของค่าใช้จ่ายเฉลีย่ของประชาชนจําแนกตามอาชีพและภาค โดย
การวเิคราะห์ความแปรปรวนแบบ 2 ทางด้วยวธีิการทดสอบแบบพาราเมตริก 
1. เปิดไฟล ์DATA15A.sav  
2. เลือกเมนู Analyze -> General Linear Model -> Univariate  

 
เลือกตวัแปร expense คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Dependent Variable 

เลือกตวัแปร occup, region คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Fixed Factor(s) 
3. คลิกปุ่ม Options  

 
เลือก Descriptive statistics 
คลิกปุ่ม Continue 



4. คลิกปุ่ม Plots  

 
เลือกตวัแปร occup คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Horizontal Axis 

เลือกตวัแปร region คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Separate Lines 
คลิกปุ่ม Add 
คลิกปุ่ม Continue 

5. คลิกปุ่ม OK จะไดผ้ลลพัธ์  

 
แสดงค่าต่างๆ ของตารางวเิคราะห์ความแปรปรวน เพื่อใชท้ดสอบสมมติฐานทางสถิติ ดว้ยค่าสถิติ F 
และความน่าจะเป็นในการยอมรับสมมติฐาน Sig. 

 จากสมมติฐานทางสถิติ 
1. สมมติฐานสาํหรับตวัแปรหรือปัจจยัท่ี 1 คือ อาชีพ 

H0 : ค่าใชจ่้ายเฉล่ียของประชาชนแต่ละกลุ่มอาชีพไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 กลุ่มอาชีพท่ีค่าใชจ่้ายเฉล่ียของประชาชนแตกต่างกนั 

2. สมมติฐานสาํหรับตวัแปรหรือปัจจยัท่ี 2 คือ ภาค 
H0 : ค่าใชจ่้ายเฉล่ียของประชาชนแต่ละภาคไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 ภาคท่ีค่าใชจ่้ายเฉล่ียของประชาชนแตกต่างกนั 



3. สมมติฐานสาํหรับผลกระทบร่วมของปัจจยัทั้ง 2  คือ อาชีพ และ ภาค 
H0 : ไม่มีผลกระทบร่วมระหวา่งกลุ่มอาชีพและภาคต่อค่าใชจ่้ายเฉล่ีย 
H1 : มีผลกระทบร่วมระหวา่งกลุ่มอาชีพและภาคต่อค่าใชจ่้ายเฉล่ีย 

การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Asymp. Sig. น้อยกว่าค่า � ทีผู้่วจิัยกาํหนด 
ปัจจยัอาชีพ ค่า Sig. ท่ีได ้มีค่าน้อยกว่าค่า � (0.026 < 0.05) 
ปัจจยัภาค ค่า Sig. ท่ีได ้มีค่ามากกว่าค่า � (0.849 > 0.05) 
ผลกระทบร่วมอาชีพและภาค ค่า Sig. ท่ีได ้มีค่ามากกว่าค่า � (0.647 > 0.05) 
การตดัสินใจ  ปฏิเสธสมมติฐานของปัจจยัอาชีพ 
  ยอมรับสมมติฐานของปัจจยัอาชีพ 
  ยอมรับผลกระทบร่วมของทั้ง 2 ปัจจยัอาชีพและภาค 
สรุปผลได้ว่า  สาํหรับปัจจยัอาชีพ มีอยา่งนอ้ย 2 กลุ่มอาชีพท่ีค่าใชจ่้ายเฉล่ียของประชาชนแตกต่าง
กนั 
  สาํหรับปัจจยัภาค ค่าใชจ่้ายเฉล่ียของประชาชนแต่ละภาคไม่แตกต่างกนั 

   สาํหรับผลกระทบร่วม ไม่มผีลกระทบร่วมระหวา่งกลุ่มอาชีพและภาคต่อค่าใชจ่้าย
เฉล่ีย 

 ถา้ผลกระทบร่วม มผีลกระทบร่วมระหวา่งกลุ่มอาชีพและภาคต่อค่าใชจ่้ายเฉล่ีย ตอ้งทอสอบต่อ 
 โดยใชค้่าสถิติท่ีอยูใ่นปุ่ม Post Hoc เพื่อทดสอบสมมติฐานสาํหรับผลกระทบจากทั้ง 2 ตวัแปร คือ อาชีพ 

และ ภาค ดงัน้ี 
H0 : ค่าใชจ่้ายเฉล่ียของประชาชนแต่ละภาคและแต่ละอาชีพไม่แตกต่างกนั 
H1 : มีอยา่งนอ้ย 2 กลุ่มภาคและอาชีพท่ีค่าใชจ่้ายเฉล่ียของประชาชนแตกต่างกนั 

 

  



แสดงกราฟเส้นของตวัแปรท่ีตอ้งการทดสอบ คือตวัแปรค่าใชจ่้าย กราฟท่ีแสดงใชค้่าเฉล่ียโดยประมาณมา
แสดงจาํแนกตามตวัแปรอาชีพ คือแกนนอน ตวัแปรภาค คือเส้นกราฟ แกนตั้งคือค่าใชจ่้ายเฉล่ีย 

การพจิารณากราฟทีไ่ด้ 
 ถา้กราฟเส้นมีลกัษณะเป็นเส้นแบบขนานกนั แสดงวา่ 2 ปัจจยันั้นไม่มีผลกระทบร่วมต่อกนั 

ถา้กราฟเส้นมีลกัษณะเป็นเส้นแบบไม่ขนานกนั แสดงวา่ 2 ปัจจยันั้นมีผลกระทบร่วมต่อกนั 
จากรูปกราฟลกัษณะของเส้นเกือบจะขนานกนั อาจสรุปไดว้า่ปัจจยัอาชีพและภาคไม่มีผลกระทบร่วมกนัต่อ

ค่าใชจ่้ายเฉล่ีย (เป็นการพิจารณาโดยประมาณอาจเกิดขอ้ผดิพลาดได)้ 
 
การวเิคราะห์ความแปรปรวนจําแนก 2 ทางแบบน็อนรพาราเมตริก 
(Two-Way Analysis of variances by NON-Parametric Method) 

เป็นวธีิการการวเิคราะห์ขอ้มูลทางสถิติท่ีใชก้บัขอ้มูลไม่สามารถใชว้ธีิการของพาราเมตริกได ้
ลกัษณะของข้อมูล คือ ขอ้มูลแต่ละกลุ่มจะตอ้งไม่เป็นอิสระต่อกนัหรือตอ้งมีความสัมพนัธ์ 
ตวัอยา่ง ผูว้จิยัตอ้งการทดสอบความพึงพอใจของผูช้มโทรทศัน์ยีห่อ้ต่างๆ 4 ยีห่อ้ และใหค้ะแนน 
              ความพึงพอใจท่ีมีระดบัคะแนน 1 ถึง 5 รวมคะแนนทั้งหมด 10 คะแนน 
กาํหนดสมมติฐานทางสถิติ 
 H0 : ระดบัความพึงพอใจเฉล่ียต่อโทรทศัน์ทั้ง 4 ยีห่อ้ไม่แตกต่างกนั 
 H1 : มีอยา่งนอ้ย 2 ยีห่อ้ท่ีมีระดบัความพึงพอใจเฉล่ียแตกต่างกนั 
การใช้โปรแกรมการวเิคราะห์ความแปรปรวนจําแนก 2 ทางแบบน็อนรพาราเมตริก 
1. เปิดไฟล ์DATA15B.sav  
2. เลือกเมนู Analyze -> Nonparametric Test -> K Related Samples  

 
เลือกตวัแปร brand1,brand2,brand3,brand4 คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Test Variables 

3. คลิกปุ่ม Statistics  

 
เลือก Descriptive 



คลิกปุ่ม Continue 



4. คลิกปุ่ม OK จะไดผ้ลลพัธ์  

 
Rank แสดงระดบัความพึงพอใจเฉล่ียของอนัดบัในแต่ละกลุ่ม 
Test Statistics แสดงค่าสถิติของ Freidman สาํหรับทดสอบสมมติฐานทางสถิติ ค่าท่ีจะนาํมาพิจารณา 
คือ ค่าความน่าจะเป็นในการยอมรับสมมติฐาน Asymp. Sig. 
การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Asymp. Sig. น้อยกว่าค่า � ทีผู้่วจิัยกาํหนด 
ค่า Asymp. Sig. ท่ีได ้มีค่าน้อยกว่าค่า � (0.046 < 0.05) 
การตดัสินใจ ปฏิเสธสมมติฐาน H0 ยอมรับสมมติฐาน H1 
สรุปผลได้ว่า มีอยา่งนอ้ย 2 ยีห่อ้ท่ีมีระดบัความพึงพอใจเฉล่ียแตกต่างกนัท่ีระดบันยัสาํคญั 0.05 

 ถา้ผูว้จิยัอยากทราบวา่มียีห่อ้ใดท่ีมีระดบัความพึงพอใจแตกต่างกนั จะตอ้งทาํการทดสอบแบบจบัคู่โดย 
วธีิของ Wilcoxon Sign Rank Test ต่อ 

 



การทดสอบค่าสัดส่วน 
การทดสอบค่าสัดส่วนสําหรับ 1 กลุ่มตวัอย่าง 

กรณีท่ีผูว้จิยัตอ้งการศึกษาโดยการตรวจสอบวา่คุณลกัษณะของข้อมูลมีจํานวนเป็นไปตามทีค่าดหวงัหรือไม่ 
การทดสอบจะไม่ทาํการทดสอบจาํนวนโดยตรงแต่จะทาํการทดสอบในรูปของสัดส่วน 
การทดสอบจาํนวนเหมือนกนัและถือวา่เป็นการทดสอบแบบน็อนพาราเมตริกอีกวิธีหน่ึง 
ประเภทของการวเิคราะห์ข้อมูลแบบ 1 ตวัแปร (Univariate) ม ี2 ประเภท 
 การทดสอบสัดส่วนกรณีท่ีขอ้มูลมีค่าเป็นไปได ้2 ค่า 
 การทดสอบสัดส่วนกรณีท่ีขอ้มูลมีค่าเป็นไปได ้ตั้งแต่ 2 ค่าข้ึนไป 
 
การทดสอบสัดส่วนกรณีทีข้่อมูลมค่ีาเป็นไปได้ 2 ค่า 
 หมายถึงขอ้มูลท่ีนาํมาทดสอบจะตอ้งสามารถจาํแนกประชากรท่ีจะศึกษาไดเ้พียง 2 ค่า (ประเภท) 

เท่านั้น  
ซ่ึงเรียกวา่ขอ้มูลประเภทน้ีวา่ ขอ้มูลมีการแจกแจงแบบทวนิาม (Binomial Distribution) เช่น เพศมี 2 เพศ 
การกาํหนดสมมตฐิานทางสถิติ 
 สมมติฐานแบบสองทาง 

H0 : สัดส่วนของประชากรไม่แตกต่างจากค่าท่ีกาํหนด หรือ H0 : � = �0 
H1 : สัดส่วนของประชากรแตกต่างจากค่าท่ีกาํหนด  หรือ H1 : � ≠  �0 

 สมมติฐานแบบทางเดียว 
H0 : สัดส่วนของประชากรมากกวา่หรือเท่ากบัค่าท่ีกาํหนด หรือ H0 : � � �0 
H1 : สัดส่วนของประชากรนอ้ยกวา่ค่าท่ีกาํหนด   หรือ H1 : � < �0 

 
H0 : สัดส่วนของประชากรนอ้ยกวา่หรือเท่ากบัค่าท่ีกาํหนด หรือ H0 : � � �0 
H1 : สัดส่วนของประชากรมากกวา่ค่าท่ีกาํหนด   หรือ H1 : � > �0 

 �  คือ ค่าสัดส่วนประชากรท่ีสนใจจะทดสอบ 
 �0 คือ ค่าสัดส่วนท่ีผูว้จิยักาํหนดเพื่อการทดสอบ 
 

ตวัอย่าง ผูว้จิยัตอ้งการทดสอบการผลิตสินคา้ชนิดหน่ึงตอ้งไดสิ้นคา้ไดม้าตรฐานไม่ต ํ่ากวา่ 90% หรือไม่ 
       ค่าขอ้มูล 1 ไดม้าตรฐาน 0 ไม่ไดม้าตรฐาน 

สมมติฐานทางสถิติสาํหรับการทดสอบกาํหนดดงัน้ี 
 H0 : จาํนวนสินคา้ท่ีไดม้าตรฐานมีมากกวา่หรือเท่ากบั  90% หรือ H0 : � � 0.90 

 H1 : จาํนวนสินคา้ท่ีไดม้าตรฐานมีนอ้ยกวา่ 90%   หรือ H1 : � < 0.90  
การใช้โปรแกรมเพือ่ทดสอบสัดส่วนเมือ่ข้อมูลมีค่าเป็นไปได้ 2 ค่า 
1. เปิดไฟล ์DATA16A.sav  
2. เลือกเมนู Analyze -> Nonparametric Test -> Binomial  



 
เลือกตวัแปร product คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Test Variable List 
Test Proportion พิมพ ์90 

3. คลิกปุ่ม OK จะไดผ้ลลพัธ์  

 
Category ค่าท่ีใชแ้ทนแต่ละประเภทของขอ้มูล 
Observed Prop. ค่าสัดส่วนของแต่ละประเภท 
Test Prop. ค่าสัดส่วนท่ีผูว้จิยักาํหนดเพื่อการทดสอบ 
Asymp. Sig. (1-tailed) ค่าความน่าจะเป็นของตวัทดสอบท่ีคาํนวณมาจากค่า Z 

การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Asymp. Sig. น้อยกว่าค่า � ทีผู้่วจิัยกาํหนดมาก่อน 
ค่า Asymp. Sig. ท่ีได ้มีค่ามากกว่าค่า � (0.175 > 0.05) 
การตดัสินใจ ยอมรับสมมติฐาน H0 
สรุปผลได้ว่า สินคา้ท่ีผลิตมีสัดส่วนไดม้าตรฐานไม่ต ํ่ากวา่ 90% ท่ีระดบันยัสาํคญั 0.05 

 



การทดสอบสัดส่วนกรณีทีข้่อมูลมค่ีาเป็นไปได้ ตั้งแต่ 2 ค่าขึน้ไป 
 การทดสอบสัดส่วนขอ้มูลท่ีมีค่าเป็นไปได ้ตั้งแต่ 2 ค่าข้ึนไป สามารถทดสอบในรูปอตัราส่วนได ้
 การทดสอบจะใชว้ธีิทดสอบของ Chi-Square : �2 เป็นการทดสอบความแตกต่างระหวา่จาํนวนหรือ

ความถ่ีท่ีไดจ้ากการสังเกต (Observed Frequency) กบั ความถ่ีท่ีคาดหวงัวา่จะเป็น (Expected Frequency) หรือ
ความถ่ีตามทฤษฎี 

การทดสอบสัดส่วนหลายกลุ่มจาก 1 กลุ่มตวัอยา่ง
  

การทดสอบสัดส่วนหลายกลุ่มจาก k กลุ่ม
ตวัอยา่ง 

1. ขอ้มูลเลือกมาจากประชากรเพียง 1 กลุ่ม 1. ขอ้มูลเลือกมาจากประชากรหลายกลุ่ม 
2. ขอ้มูลท่ีถกูจาํแนกเป็นประเภทหรือกลุ่มท่ีเกิดจากตวั
แปรท่ีมีค่าเป็นไปไดห้ลายค่านั้นมีความสัมพนัธ์กนั 

2. ขอ้มูลแต่ละกลุ่มเกิดจากการเกบ็ขอ้มูลแยกกนั
มาแต่ตน้และไม่เก่ียวขอ้งกนัหรือเป็นอิสระต่อ
กนั 

3. ถา้ยอมรับสมมติฐาน H0 หมายความวา่ สัดส่วนใน
แต่ละประเภทมีค่าไม่แตกต่างกนั 

3. ถา้ยอมรับสมมติฐาน H0 หมายความวา่ 
สัดส่วนในแต่ละกลุ่มมีค่าไม่แตกต่างกนั 

ตวัอย่าง ผูว้จิยัคิดวา่ยอดขายโทรทศัน์ยีห่อ้ต่างๆ ต่อเดือนคือ Sony, Samsung, อ่ืนๆ น่าจะเป็นอตัราส่วน  
5:3:2 
ค่าขอตวัแปร 1 Sony 2 Samsung  3 อ่ืนๆ 
สมมติฐานทางสถิติสาํหรับการทดสอบกาํหนดดงัน้ี 
 H0 : ยอดขายยีห่อ้ Sony, Samsung, อ่ืนๆ เป็นอตัราส่วน 5:3:2 
 H1 : ยอดขายยีห่อ้ Sony, Samsung, อ่ืนๆ ไม่เป็นอตัราส่วน 5:3:2 
การใช้โปรแกรมเพือ่ทดสอบอตัราส่วนเมือ่ข้อมูลมค่ีาเป็นไปได้ตั้งแต่ 2 ค่าขึน้ไปสําหรับ 1 กลุ่มตวัอย่าง 
1. เปิดไฟล ์DATA16B.sav  
2. เลือกเมนู Analyze -> Nonparametric Test -> Chi-Square  

 
เลือกตวัแปร product คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Test Variable List 



Values  พิมพ ์5 คลิกปุ่ม Add 
  พิมพ ์3 คลิกปุ่ม Add 
  พิมพ ์2 คลิกปุ่ม Add 

3. คลิกปุ่ม OK จะไดผ้ลลพัธ์  

 
 

Observed N จาํนวนหรือความถ่ีของขอ้มูลท่ีเกบ็รวบรวมมาจาํแนกตามค่าท่ีเป็นไปได ้
Expected N จาํนวนหรือความถ่ีท่ีคาดหวงัตามค่าท่ีเป็นไปได ้
Residual ผลต่างของความถ่ีทั้ง 2 ถา้มีค่ามากแสดงวา่ขอ้มูลท่ีเกบ็มาไม่เป็นไปตามท่ีคาดหวงั 

Test Statistics 
Chi-Square ค่าสถิติ Chi-Square 
Asymp. Sig. ค่าความน่าจะเป็นใชใ้นการยอมรับสมมติฐาน 

การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Asymp. Sig. น้อยกว่าค่า � ทีผู้่วจิัยกาํหนดมาก่อน 
ค่า Asymp. Sig. ท่ีได ้มีค่ามากกว่าค่า � (0.127 > 0.05) 
การตดัสินใจ ยอมรับสมมติฐาน H0 
สรุปผลได้ว่า ยอดขายยีห่อ้ Sony, Samsung, อ่ืนๆ เป็นอตัราส่วน 5:3:2 ท่ีระดบันยัสาํคญั 0.05 

 



การทดสอบค่าสัดส่วนสําหรับหลายกลุ่มตวัอย่างทีเ่ป็นอสิระต่อกนั 
เป็นการทดสอบค่าสัดส่วนกรณีขอ้มูลของแต่ละกลุ่มมีเพียง 2 ค่า 
การทดสอบจะใชว้ธีิทดสอบของ Chi-Square : �2 
ตวัอย่าง จากการสาํรวจผูท่ี้ชอบรายการโทรทศัน์รายการหน่ึงในแต่ละภาคมีสัดส่วนต่างกนัหรือไม่ 
ค่าตวัแปร 1 ชอบ 0 ไม่ชอบ 
สมมติฐานทางสถิติสาํหรับการทดสอบกาํหนดดงัน้ี 
 H0 : จาํนวนผูท่ี้ชอบรายการโทรทศัน์แต่ละภาคมีสัดส่วนไม่แตกต่างกนั 
 H1 : จาํนวนผูท่ี้ชอบรายการโทรทศัน์แต่ละภาคมีสัดส่วนแตกต่างกนั 
การใช้โปรแกรมเพือ่ทดสอบค่าสัดส่วนของข้อมูลหลายกลุ่มตวัอย่างเป็นอสิระกนั 
1. เปิดไฟล ์DATA17A.sav  
2. เลือกเมนู Analyze -> Descriptive -> Crosstabs  

 
เลือกตวัแปร test คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Row(s) 

เลือกตวัแปร region คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Column(s) 
3. คลิกปุ่ม Statistics  

 



เลือก Chi-square 
คลิกปุ่ม Continue 

4. คลิกปุ่ม Cells  

 
เลือก Expected 
คลิกปุ่ม Continue 



5. คลิกปุ่ม OK จะไดผ้ลลพัธ์  

 
การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Asymp. Sig. (2-sided)น้อยกว่าค่า � ทีผู้่วจิัยกาํหนดมา
ก่อน คือ 0.05 
ค่า Asymp. Sig. (2-sided) ท่ีได ้มีค่ามากกว่าค่า � (0.841 > 0.05) 
การตดัสินใจ ยอมรับสมมติฐาน H0 
สรุปผลได้ว่า จาํนวนผูท่ี้ชอบรายการโทรทศัน์แต่ละภาคมีสัดส่วนไม่แตกต่างกนั ท่ีระดบันยัสาํคญั 0.05 

 
การทดสอบค่าสัดส่วนสองกลุ่มตวัอย่างที่มคีวามสัมพนัธ์กนั 

เป็นการทดสอบค่าสัดส่วนของ 2 กลุ่มตวัอยา่ง ขอ้มูลแต่ละกลุ่มมีค่าเพียง 2 ค่า ขอ้มูลทั้ง 2 กลุ่มมีความ 
สมพนัธ์กนั 
การทดสอบจะใชว้ธีิทดสอบของ Mcnemar และเป็นการทดสอบแบบน็อนพาราเมตริก 
ถา้ขอ้มูลตวัอยา่งมีขนาดใหญ่ ขอ้มูลจะมีการแจกแจงใกลเ้คียงแบบปกติจะใชว้ธีิทดสอบ Chi-Square : �2 
ตวัอย่าง จากการสอบถามความพอใจของผูใ้ชบ้ริการของรถไฟก่อนและหลงัการปรับปรุงการใหบ้ริการ 
ค่าตวัแปร 1 พอใจ 2 ไม่พอใจ 
สมมติฐานทางสถิติสาํหรับการทดสอบกาํหนดดงัน้ี 
 H0 : สัดส่วนของผูต้อบวา่ พอใจ ก่อนและหลงัการปรับปรุงไม่แตกต่างกนั หรือ H0 : �1 = �2 
 H1 : สัดส่วนของผูต้อบวา่ พอใจ ก่อนและหลงัการปรับปรุงแตกต่างกนั หรือ H1 : �1 ≠ π 2 
การใช้โปรแกรมเพือ่ทดสอบค่าสัดส่วนของข้อมูล 2 กลุ่มตวัอย่างทีม่คีวามสัมพนัธ์กนั 
 สามารถทาํได ้2 วธีิ 
 Analyze -> Descriptive Statistics -> Crosstabs คลิกปุ่ม Statistics เลือก McNemer 
 Analyze -> Nonparametric Tests -> 2 Related Samples 

1. เปิดไฟล ์DATA17B.sav 
2. เลือกเมนู Analyze -> Descriptive Statistics -> Crosstabs 



 
เลือกตวัแปร pre คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Row(s) 

เลือกตวัแปร post คลิกปุ่ม  เกบ็ไวใ้นบ๊อกซ์  Column(s) 
3. คลิกปุ่ม Statistics 

 
เลือก McNemar 
คลิกปุ่ม Continue 



4. คลิกปุ่ม OK จะไดผ้ลลพัธ์ 

 
Exact Sig. (2-sided) คือ ค่าความน่าจะเป็นในการยอมรับสมมติฐาน 
การตดัสินใจจะปฏิเสธสมมตฐิาน H0 ถ้าค่า Asymp. Sig. (2-sided)น้อยกว่าค่า � ทีผู้่วจิัยกาํหนด 
มาก่อน คือ 0.05 
ค่า Asymp. Sig. (2-sided) ท่ีได ้มีค่าน้อบกว่าค่า � (0.029 < 0.05) 
การตดัสินใจ ปฏิเสธสมมติฐาน H0 
สรุปผลได้ว่า สัดส่วนของผูต้อบวา่ พอใจ ก่อนและหลงัการปรับปรุงแตกต่างกนั 
จาํนวนผูท่ี้พึงพอใจก่อนและหลงัการปรับปรุงแตกต่างกนั จะตอ้งแปลความหมายต่อไปวา่ แตกต่าง

กนัในทางท่ีดีหรือแยล่ง โดยพิจารณาตวัเลขจากตาราง pre * post Crosstabulation  จาํนวนผูพ้อใจก่อน
ปรับปรุงมี 10 คน จาํนวนผูพ้อใจหลงัปรับปรุงมี 22 คน ดงันั้นสามารถสรุปไดว้า่การปรับปรุงการ
ใหบ้ริการจะมีผลทาํใหผู้ใ้ชบ้ริการเปล่ียนทศันคติต่อความพึงพอใจทาํใหพ้อใจมากข้ึน 

 
 


